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Safety Guidelines 

This manual contains notices intended to ensure personal safety, as well as to protect the products and 

connected equipment against damage. These notices are highlighted by the symbols shown below and 

graded according to severity by the following texts: 

 

!  
Danger 
indicates that death, severe personal injury or substantial property damage will result if proper 
precautions are not taken. 

 

!  
Warning 
indicates that death, severe personal injury or substantial property damage can result if proper 
precautions are not taken. 

 

!  
Caution 
indicates that minor personal injury can result if proper precautions are not taken. 

 
 Caution 

indicates that property damage can result if proper precautions are not taken. 

 
 Notice 

draws your attention to particularly important information on the product, handling the product, or to a 
particular part of the documentation. 

Qualified Personnel 

Only qualified personnel should be allowed to install and work on this equipment. Qualified persons 

are defined as persons who are authorized to commission, to ground and to tag circuits, equipment, and 

systems in accordance with established safety practices and standards. 

Correct Usage 

Note the following: 

 

!  
Warning 
This device and its components may only be used for the applications described in the catalog or the 

technical description, and only in connection with devices or components from other manufacturers 

which have been approved or recommended by Siemens. 

 
This product can only function correctly and safely if it is transported, stored, set up, and installed 
correctly, and operated and maintained as recommended. 

Trademarks 

SIMATIC®, SIMATIC HMI® and SIMATIC NET® are registered trademarks of SIEMENS AG.  

Third parties using for their own purposes any other names in this document which refer to trademarks 

might infringe upon the rights of the trademark owners. 
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Designing a Sequential Control System Based on 
the Example of a Drill 

Welcome to the S7-GRAPH Beginner's Example 

If you take an hour to work through the beginner's example, you will learn how to 
create a sequential control system for automating the drill as described below. 

  

You first learn how to configure a sequential control system efficiently and will then 
be guided step by step through the tasks you need to perform in the SIMATIC 
Manager and in S7-GRAPH so that you can 

• create the sequential control system,  

• download it to the CPU and 

• test it. 

The correctly programmed sample is supplied with S7-GRAPH as a project called 
"ZEn02_01_S7GRAPH_Drill".  
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Requirements 

To allow you to program and test the "drill" example, you require the following 
hardware and software: 

• Programming device/PC with  

-  STEP 7 standard package and the S7-GRAPH optional package 

-  MPI connection to the programmable logic controller 

• A programmable logic controller (in our example an S7-300) consisting of the 
following: standard rail, 24V power supply, CPU 314, and a digital input/output 
module (8DI + 8DO) 

• As an alternative to the PLC: The "PLC Simulation" S7 optional package 

Procedure for Creating a Sequential Control System 

The flow diagram illustrates the procedure for creating the sequential control 
system for the drill example: 

Create symbol table

Specify structure of sequencer
and define signals for system

Create drill project in the
SIMATIC Manager

Create sequencer:
• create and open S7 Graph FB1 in

the SIMATIC Manager
• Program sequencer

Program OB1 with FB1 call and
corresponding instance DB (DB1)

Download sample program (DB1, FB1,
OB1) to the CPU in the SIMATIC
Manager and test the sequencer

Symbolic
programming

yes

no
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Technological Task and Functional Diagram 

Task 

You want to program a sequential control system to automate a drill. The setup of 
the drill is shown by a technological drawing and the process sequence in the form 
of a function diagram. 

Technological Drawing - Set Up of the Drill 

The drill consists of the following elements: 

• Drill motor with feedback signals for drill running/stopped 

• Start button and coolant switch 

• Cooling pump with feedback signal for coolant pressure reached 

• Clamping device with feedback signal for selected clamp pressure reached 

• Carriage raise/lower drill with limit switches for drill up/down 

Raise drill
Drill motor on
Feedback signal:
- Drill running

- Drill stopped

Cooling pump on
Feedback signal
Coolant pressure reached

Start button

Feedback signal:

Selected clamping pressure
reached

Limit switch:
Drill up

Limit switch:
Drill down

Coolant switch

Drill motor

Carriage

Clamp deviceCooling pump

Lower drill
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Initial State 

The initial state of the drill is defined as follows: 

• The drill motor and cooling pump are stopped 

• The carriage/drill is in the upper position 

• There is no work piece in the clamping device 

Functional Diagram - Drilling Sequence 

The entire drilling sequence can be divided into the following sections: 

• Insert work piece (manual) 

• If required, set switch for coolant (depending on the material) 

• Start the machine with the start button (drill motor starts up) 

• Clamp the work piece with the selected clamp pressure 

• Start the cooling pump (if coolant selected) 

• Lower drill and carriage to the bottom target position (drill) 

• Wait 0.5 seconds at lower target position (drill) 

• Raise drill with carriage to upper target position 

• Remove work piece, turn off drill motor and cooling pump 

• Remove work piece (manual) 

Motor
running

stopped

Carriage
up

down

Element State

Clamping
device

On

Off

Start
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Selecting the Structure of the Sequencer 

Before you create the program for the sequencer, you should include a concept 
phase in which you break down the drilling operation into single steps. The basis of 
the concept design is the technological drawing and the flowchart. 

Dividing the Drilling Process into Individual Steps - Structure of the Sequencer 

The drilling process is described by S7-GRAPH in the form of a sequencer. A 
sequencer represents a sequence of single steps and conditions that control how 
the process moves on to the next single step. To specify the structure of the 
sequencer, follow the steps outlined below: 

1. Break down the drilling process into steps and specify the order of the steps (for 
example "step S2 follows S1" or "step S3 follows either step S4 or S7"). 

2. For each step, specify the actions that must be performed in the step (for 
example in S1 the action "Drill ready" or in S3 the action "Turn on drill motor"). 

3. Then decide for every step which conditions must be met so that the process 
can move on to the next step (for example for T1 the condition "Drill started - 
start button pressed" or for T5 the condition "Drill in upper position"). 

T2

S2

T8

T3

T7

S3

S1

T4

T1

T6

S7

S4

Drill ready (initial step)

Clamp work piece

Turn on drill motor

Turn on cooling pump

Lower drill (start drilling)

Drill program started (start button
pressed)

Work piece clamped with selected
pressure

Drill motor running at selected speed
(without coolant)

Coolant pressure reached

Drill in lower position

Drill motor running at selected speed
(with coolant)

S5

S6

T5

T6

S1

Raise drill

Release work piece, turn off drill motor
and cooling pump

Drill in upper position

Work piece is released, cooling
pump stopped, drill motor stopped
Waiting time 500 ms

S = step
T = transition

Monitor clamping
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Defining the System Signals 

Once you have broken down the drilling operation into individual steps, you should 
then define the input and output parameters for each step. The basis of the 
concept design is the technological drawing and the flowchart. 

Defining Inputs and Outputs 

List the inputs and outputs for the drill in the form of a table.  

If you want to program symbolically, enter the required symbolic names (for 
example input I 0.4 "Cl_press_ok") for the absolute inputs and outputs and any 
comments that will make the program easier to understand (for example 
"Workpiece clamping pressure reached"). 

In the drill example, it is assumed that the switches and contactors of the drill are 
controlled via the inputs and outputs of the digital input/output module of the 
S7-300 programmable controller. The input/output module has 8 inputs and 8 
outputs. The default values of the input and output addresses of the module 
inserted in slot 4 are as follows: I 0 to I 0.7 and Q =0.0 to Q 0.7. 

 

Absolute 
Addresses 

Symbolic  
addresses 

Explanation 
 

Inputs in the program (I)  

I 0.0 Dr_mot_running Feedback signal for drill running at selected speed 

I 0.1 Dr_mot_stopped Feedback signal for drill stopped 

I 0.2 Drill_down Limit switch for drill in lower position 

I 0.3 Drill_up Limit switch for drill in upper position 

I 0.4 Cl_press_ok Feedback signal for work piece clamping pressure 
reached 

I 0.5 Coolant_sel Selector for coolant (dependent on work piece) 

I 0.6 Cool_press_ok Feedback signal for coolant pressure reached 

I 0.7 Start_button Start button of the drill 

Outputs in the program (Q)  

Q 0.0 Dr_mot_on Turn on drill motor 

Q 0.1 Cool_pump_on Turn on cooling pump (dependent on work piece) 

Q 0.2 Lower_drill Lower drill and carriage to bottom limit position 

Q 0.3 Raise_drill Raise drill and carriage to the upper limit position 

Q 0.4 Clamp_workp Clamp work piece at required pressure 
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Creating the Drill Project in the SIMATIC Manager 

Creating a Project 

Projects for sequential control systems do not differ from other projects in STEP 7. 

To create a new project in the SIMATIC Manager, follow the steps outlined below: 

1. Select the menu command File > New.  

2. Name the project "Drill". 

Inserting an S7 Program 

In this example, hardware configuration is unnecessary since the default 
addressing of the input/output module in slot 4 is used. You can therefore 
immediately insert an S7 program in the project folder in the SIMATIC Manager. 
The S7 program serves as a folder for the blocks of the user program, the source 
files and the symbols. Follow the steps below: 

1. Select the "Drill" project. 

2. Select the menu command Insert > Program > S7 Program. 

3. Name the S7 program "Drill Program". 

The folders for source files, blocks, and symbols are created automatically when 
you insert an S7 program. An empty OB1 is also created in the Blocks folder. 
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Creating a Symbol Table 

When you program in STEP 7, you work with addresses such as I/O signals, 
memory bits, counters, timers, data blocks, and function blocks. You can access 
these addresses in your program in absolute format (for example I1.1, M2.0, 
FB21). 

You will find the program much clearer and easier to read if you use symbols (for 
example Motor_A_on) instead of the absolute addresses. To allow the use of 
symbols, you can enter a name, the absolute address, the data type and a 
comment for every address used. 

Once you have defined a symbol, it can be used throughout the entire user 
program of a programmable module. 

Creating a Symbol Table 

If you want to write your program using symbolic addresses, it is advisable to 
create the symbol table at this point.  

1. Open the symbol table in the "Drill Program" folder by double-clicking 
"Symbols". 

2. Edit the table as shown below.  

3. Save the symbol table using the menu command Table > Save. 

The entries 1 to 14 are required for symbolic representation of the inputs and 
outputs. The entries 15 to 18 allow symbolic representation of the blocks.  
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Creating an S7-GRAPH FB and Programming a Sequencer 

Creating an S7-GRAPH FB 

The S7-GRAPH FB will contain the sequencer. To create an S7-GRAPH FB, follow 
the steps outlined below: 

1. Open the "Blocks" folder in "Drill Program" in the SIMATIC Manager. 

2. Select the menu command Insert > S7 Block > Function Block. 

3. Set "S7-GRAPH" as the language in the "Properties" dialog box.  

Result: The empty FB with the default number 1 is created in the "Blocks" 
folder. 

Programming a Sequencer 

After you have started the S7-GRAPH editor by double-clicking FB1 the system 
inserts the first step (initial step) and the first transition. It is advisable to create the 
structure at the "Sequencer" display level. To display conditions and actions, 
activate the View > Display With > Conditions and Actions menu command. 

Using the mouse and the "Sequencer" toolbar at the left-hand edge of the screen, 
you can then position all the remaining steps and transitions, the alternative 
branch and the jump from the end of the sequencer to the start of the sequencer. 
There are two ways of doing this and both are illustrated here. 

Method 1: "Direct" Mode 

1. Select transition 1 and click with the mouse until the icon  

  insert step + transition 
until you arrive at step/transition 6. 

2. Select step 3 and then select the icon 

  open alternative branch.  
This opens the alternative branch for supplying coolant. The branch begins with 
transition 7.  

3. With the mouse, select the icon  

   insert step + transition,  
and insert step 7 (S7) and transition 8 (T8).  

4. Select the icon 

  close alternative branch 
and then select transition 3. 

5. Now complete the sequencer structure by first selecting transition 6 and then 
clicking on the icon 

   insert jump 
and then selecting step 1. 
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Method 2: "Drag-and-Drop" 

1. Return to the SIMATIC Manager and create function block FB2 in the "Blocks" 
folder as described above. Once again select "GRAPH" as the source 
language. 

2. Start the S7-GRAPH editor by double-clicking FB2 in the "Blocks" folder. 

3. Select the menu command Insert > Drag-and-Drop. 

4. With the mouse, select the icon 

  insert step + transition 
and then click on the last transition of the individual elements until you arrive at 
step/transition 6. 

5. Select the icon 

   open alternative branch 
and open the alternative branch for the coolant by clicking on step 3. The 
branch begins with transition 7.  

6. With the mouse, select the icon 

  insert step + transition,  
to insert step 7 (S7) and transition 8 (T8).  

7. Select the icon 

   close alternative branch 
and first select transition 8 and then transition 3. 

8. Now complete the sequencer structure with 

 insert jump 
by first selecting transition 6 and then step 1. 

 

 Note 

Close fFB2 before you start to program step actions.. You only created this FB to 
try out the second method of creating a sequencer structure. When you close the 
FB, answer all prompts with "No". For the rest of the exercise, you will be working 
in FB1. 
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Programming Step Actions  

There are also two methods available for programming step actions and 
transitions: Direct and Drag-and-Drop. The procedure described below assumes 
you have selected the menu command Insert > Drag-and-Drop:  

1. Select the menu command Insert > Action.  
Result: The mouse pointer then appears as shown below:  

 

2. Insert an empty action line by clicking the action box.  

3. Enter the actions. 

An action consists of an instruction and an address. For the drill program, four 
different instructions are necessary in the steps: 

• S Set output 

• R Reset output 

• N Non holding: As long as the step is active,   
 the signal state of the address is 1. 

• D Delay: The address is set to 1 after the defined time has elapsed 
following activation of the step and is reset when the step is deactivated. 

Programming Transitions 

The bit logic instructions "normally open contact", "normally closed contact" and 
"comparator" are used for the step enabling conditions in the transitions. To 
program transitions: 

1. Set the "LAD" view and select the appropriate icons in the "LAD/FBD" toolbar 

  insert normally-open contact 

  insert normally-closed contact 

  insert comparator 

2. Position the symbols at the appropriate points by clicking the transition lines. 
You can exit the insert mode at any time with the ESC key. 

3. Enter the addresses. Click the placeholder "??.?" of the required text field. Then 
enter an absolute or symbolic address (for example I 0.7, "Start_switch"). 

4. If you wish, you can also enter a comment for the sequencer. In the 
"sequencer" view, the comment field is at the top left and can be opened by 
clicking it with the mouse. 
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The following figure shows the completed sequencer. 

GRAPH: Programming s7 Sequential Control Systems - Drill\...
File Edit Insert PLC Debug View Options Window Help

Drill

T1

Trans1

T4

Trans4
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"Drill_mot
or_stopped
"

>=

 

When programming comparators, you can use the system information for steps as 
the addresses. The addresses have the following significance: 

• Step_name.T: current or last activation time of the step 

• Step_name.U: current or last activation time of the step without the time of a 
disturbance 
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Programming Monitoring Functions 

To program monitoring functions: 

1. Double-click on step 2 to change from the "sequencer" view to the "single step " 
view. 

2. Select the icon 

 insert comparator in the "LAD/FBD" toolbar 

3. Position the comparator at the appropriate point on the supervision line and 
enter the required monitoring time. 
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Specifying the Standard Function Block 

Executability of the S7-GRAPH FB 

S7-GRAPH has two options available for creating FBs. 

• Full code: 
The entire code required to execute each S7-GRAPH FB is included in the FB. 
If you have several S7-GRAPH FBs, this means a considerable increase in 
memory requirements. 

• Standard FC required: 
To reduce memory requirements, S7-GRAPH has the two following alternatives: 
You use a standard FC containing the main code sections for all FBs. This FC 
is copied to your project automatically when you select this option. The FBs 
produced using this method are considerably smaller.  

For this example, use the compilation option "Full code".  

The most suitable FC depends on the performance of your CPU. Select one of the 
following standard FCs: 
 

FC Number Functionality 

FC72 As default, you work with FC72. Remember, that your CPU must be capable of processing 
blocks with more than 8 Kbytes.  

FC70/FC71 These two FCs are less than 8 Kbytes in size and can therefore be loaded on a smaller 
CPU. FC70 uses the diagnostic functionality of SFC17/18 and can only be used on CPUs 
that have these functions available. If your CPU does not have these functions, you must 
use FC71 and do without diagnostic capability.  

If you want to check whether or not your CPU contains these SFCs, select the menu 
command PLC > Obtainable Nodes in the SIMATIC Manager or click the corresponding 
button in the toolbar. Open the "Blocks" folder in the S7 program. 

FC73 This block requires less than 8 Kbytes of memory so that it can be executed on all CPUs.  

Using this FC considerably reduces the memory requirements of the S7-GRAPH FBs. You 
must also select the option "Interface Description: Memory minimized" in the block settings.  

The following restrictions, do, however, apply:  

The blocks created do not have diagnostic capability 

When you monitor the sequential control system, you will see the status display only for the 
selected active element. 
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Setting the Executability 

Select the menu command Options > Block Settings and specify that the 
S7-GRAPH FB can be executed with a standard FC in the Compile/Save tab. Enter 
the FC number that matches the performance of your CPU. 

The block is automatically copied to the user project if you select FC70/71, FC72 or 
FC73 as the block number and there is not yet an FC with this number in the target 
project. If you want to use a different number for the standard block, you must copy 
and renumber yourself. 

Saving and Closing the Sequencer 

When you save the sequencer, it is automatically compiled. 

1. Select the menu command File > Save. 

Result: The "Select Instance DB" dialog box is opened with the default instance 
DB (DB1). 

2. Accept the settings by clicking "OK". 

Result: The instance data block is automatically created in the "Blocks" folder. 

 

 Note 

The warning "S1 without content" in the compiler log simply means that no action 
is programmed in step 1. 

 

3. To close the sequencer, select the menu command File > Close. 
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Including the Sequencer in the STEP 7 Program 

Programming OB1 

The sequential control program for the drill is called and started in organization 
block OB1. You can create OB1 in LAD, FBD, STL or SCL (here it was created in 
LAD). Program OB1 as shown in the following diagram. Follow the steps below: 

1. Open the "Blocks" folder in the "Drill Program" S7 program in the 
SIMATIC Manager. 

2. Start the LAD/STL/FBD editor by double-clicking OB1. 

3. With the menu command View, select the programming language LAD. 

4. Select segment 1 and insert the sequencer call using the program element 
catalog by double-clicking FB1 (Seq_drill). 

5. Type in the name of the corresponding instance data block (IDB_Seq_drill) 
above the LAD box. 

6. Select the input parameter INIT_SQ, insert a normally open element using the 
"LAD" toolbar and label it M0.0 ("INIT_SQ"). Using this parameter, you can set 
the sequencer to the initial step (in the example step 1) in the online mode. 

7. Select the menu command File > Save and close the organization block with 
the menu command File > Close. 

 

 Note 

All other block parameters can be ignored for the example. 
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Downloading the Program to the CPU and Testing the 
Sequencer 

Downloading the User Program 

To allow you to download the program to the CPU, you must download all the 
blocks (DB1, FB1, OB1, FC70/71, FC72 and/or. FC73) to the CPU of the 
programmable controller in the SIMATIC Manager. Follow the steps outlined 
below:  

1. Open the "Drill Program" S7 program in the SIMATIC Manager and select the 
"Blocks" folder. 

2. Select the menu command PLC > Download. 

 

 Caution 

It is best to download the S7-GRAPH block in the STOP mode since following 
downloading of the instance DB, the sequencer is automatically set to the initial 
state. 

You should only download S7-GRAPH blocks in the RUN-P mode when the 
sequencer is in the initial state or in the OFF state. If you download the blocks the 
sequencer in a different state, for example when overwriting an old block, problems 
may occur in the synchronization of the sequencer with the process. 

Testing the User Program 

To test the user program, you require an online connection to a CPU. 

1. Open the project window in the SIMATIC Manager. 

2. Open the sequencer by double-clicking FB1.  

3. Select the menu command Debug > Monitor. 

Result: The program status is displayed (the initial step is active). Active steps 
are displayed in color. 

 

 Caution 

A monitoring time is programmed in step 2. If the step activation time exceeds the 
configured monitoring time (500 ms) in the supervision condition, the system 
recognizes a supervision error and the disturbed step is displayed in red. If a fault 
occurs, you must first satisfy the condition for progressing to the next transition. 
Using the PG function  Debug > Control Sequencer  you can then enter an 
acknowledgment (see also "Control Sequencer"). 

This does not apply to the inching mode, since the step enabling condition must be 
satisfied and the acknowledgment received within one cycle. 
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Test Function: Control Sequencer  

Control Sequencer is a test function with which you can test the sequencer in 
S7-GRAPH in all modes. All the settings and entries for the dialog box have the 
same effect as the corresponding FB parameters.  

The entries in the "Control Sequencer" dialog box can be different from the settings 
you used to compile the sequencers. The dialog box settings have priority. 

"Control Sequencer" Dialog box 

The "Control Sequencer" dialog box is used both as an output field that displays 
the current settings and as an input field in which you can change the current 
status.  

If you acknowledge an error, initialize the sequencer, or want to change the step in 
the manual mode, call the dialog box with the menu command Debug > Control 
Sequencer. 

Acknowledge 

If the "Acknowledge errors" option is clicked, you acknowledge a pending error 
message with the "Acknowledge" button. In this way, you can acknowledge a 
disturbance caused, for example, by the configured monitoring time in Step 2 being 
exceeded.  

Note, however, that before you acknowledge the error you must make sure that the 
supervision or interlock conditions that led to the error are no longer satisfied. 

After an error has occurred, you can enable the next step in the sequencer by 
satisfying the step enable condition because the last step enable condition in the 
cycle in which you acknowledge has priority over the supervision. You must 
nevertheless acknowledge the error. 

If the error was caused because the undisturbed activation time stepname.U has 
exceeded the configured monitoring time, you can move on the sequencer by 
clicking the "Acknowledge" button. 

This is possible because the Step name.U variable is set to "0" when you 
acknowledge. 

Initialize 

With the "Initialize" button, you can restart the sequencer completely with the 
defined initial step. 
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Setting the Mode 

Checkmark on the check boxes to set the corresponding selected mode for the 
sequencer 

You can, for example, run your sequencer in the manual mode instead of the 
automatic mode. In the manual mode, you can activate or deactivate any step. 
Follow the steps outlined below: 

1. Enter the step number of the step you want to process in the "Step number" box 
or simply click the required step. 

2. Select the action to be executed with the step: 

- Activate The selected step is activated even if the preceding transition is 
not satisfied. 

- Deactivate The selected step is deactivated. 

Note that before you activate a step you must first deactivate the currently active 
step since only one step can be active at any one time in a linear sequencer. In 
other words, you can only activate the required step when you have deactivated 
the currently active step. 

If you have set a new mode, the original mode is indicated in bold face. 

After you have controlled your sequencer in the manual mode, you can return to 
the automatic mode and close the "Control Sequencer" dialog box. 

Modifying the Sequencer 

Often, a program does not run as required at the first attempt. This means that 
changes and modifications are required. This is also the case in our sample 
program. The configured watchdog time in Step 2 is too short and the program 
hangs at this step. The following section explains how to make the required 
changes. You must first change to the "offline" mode. 

Modifying the Watchdog Time 

The watchdog time configured in Step 2 is 500 ms. To give you more time for 
setting the "Cl_press_ok" variable, change the watchdog time to 5 s as explained 
below: 

1. Double-click on step 2 to change from the "sequencer" view to the "single step " 
view. 

2. Close the status by selecting the menu command Debug > Monitor or clicking 

the following button:   . 

3. Enter the value 5 s for the monitoring time. 

4. Save the sequencer with the menu command File > Save, since the sequencer 
must be recompiled. 
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Downloading the Modified Sequencer 

Once you have compiled the sequencer, you must download it to the CPU. You 
can download the sequencer in the SIMATIC Manager or in the S7-GRAPH editor. 
In the S7-GRAPH editor, follow the steps outlined below:  

1. With the FB open, select the menu command PLC > Download or click on the 

Download button . The "Download" dialog box is opened. 

2. Accept the defaults by clicking "OK". 

3. Confirm the prompt to overwrite the existing blocks. 

Include Instance DB 

If you have not cleared the system default "Include Instance DB", S7-GRAPH 
checks whether the instance DB has changed since it was last downloaded and 
whether it must be updated. The option "Download with Instance DB" is enabled in 
the "Download" dialog box.  

Otherwise, S7-GRAPH does not check the instance DB and leaves you to decide 
whether or not to download the instance DB again. The option "Download with 
Instance DB" is not clicked in the "Download" dialog box. 

Restarting the Status 

To be able to monitor or control the sequencer again, restart Status by selecting 

the menu command Debug > Monitor or by selecting the Monitor  button. 
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