Windows 98 Supplemental Lab Exercises 

Exercise 1 - Discover the Windows 98 Setup switches

Insert the Windows 98Setup CD.  Click Start->Run and enter [d:]\WIN98\SETUP /?  
(where [d:] is the CDROM drive letter.
Click OK after reading the options screen.

There are many more Setup parameters that can modify a Windows installation:

Windows 98/95 SETUP SWITCHES
If you try to install Windows 95/98 from a DOS prompt, SETUP allows
several command line switches. Some are also available if you perform an Upgrade
installation from within Windows:
SETUP /?
"Setup Options: SETUP [/C] [/IL] [batch] [/T:TMP] [/IM] [/ID] [/IS]
[/IQ] [/IN]


/C Instructs Setup not to load the SmartDrive disk cache.
/IL Loads the Logitech mouse driver instead of the Microsoft mouse
driver. Use this option if you have a Logitech Series C mouse.
[batch] Specifies the name and location of the file that contains Setup
options.
/T:TMP Specifies the directory where Setup will copy its temporary
files. If the directory doesn't exist, it will be created.
WARNING: Any existing files in this directory will be deleted.
/IM Skips the memory check.
/ID Skips the disk-space check.
/IS Doesn't run ScanDisk.
/IQ Skips the check for cross-linked files.
/IN Runs Setup without the Network Setup module.
Note: The /a and /n options are no longer valid. Use NETSETUP.EXE
instead."

*******************

NEW Setup switches added by Windows 98:
/ie Does not create an Emergency Boot Disk.
/ih Skips the registry check.
/iv Skips the display of billboards during setup.

UPDATES: "Undocumented SETUP switch:
/IW Bypasses Microsoft EULA licensing screens/dialog boxes. [EULA = End
User License Agreement]."
/NTLDR Bypasses an existing Operating System detection. By default
OEM/VAR Win95/NT full releases can be installed ONLY on a new PC,
without ANY previous OS, but this switch allows SETUP to circumvent this
"problem".
/Pf Creates a NEW Win95 Registry from scratch, in the case of corrupted
registry files [BACKUP your WORKING WIN98/95 REGISTRY FILES FIRST]!
Also read the "FRESH REGISTRY" topic (included) for more "SETUP /Pf"
details.
/nm Bypasses the internal processor detection, to allow Win95/98 install
on systems that do NOT meet Microsoft minimum requirements (i.e. 386,
486SX etc). Also skips the check for the math coprocessor. Works
especially for Windows 98!

Also read these Microsoft Knowledge Base articles to learn
everything about the "official" SETUP switches:
1. "Windows 95 Setup Switches":
http://support.microsoft.com/support/kb/articles/Q128/4/00.asp
and:
2. "Description of the Windows 98 Setup Switches":
http://support.microsoft.com/support/kb/articles/Q186/1/11.asp
Clean Installation of Windows 98


After you partition and format your hard disk, you can install Windows 98:

Insert the Windows 98 Startup/Boot disk in your floppy disk drive, and then restart your computer.

When the Windows 98 Startup/Boot menu is displayed, select the Start computer with CD-ROM support menu option, and then press Enter.

Insert the Windows 98 CD-ROM in the CD-ROM drive, type the following at the command prompt X: and then press Enter.

Now that you are at the X: prompt type setup

**NOTE**

"X" is the drive letter that is assigned to your CD-ROM drive in these instructions.

When you receive this message, Please wait while the Setup initializes.

Setup is now going to perform a routine check on your system. To continue press Enter. Press Enter.

Follow the instructions on the screen to complete the Setup procedure:

Windows 98 Setup can be divided into the following phases:

   1. Pre-file copy phase

   2. File copy phase

   3. Enumeration/detection phase

   4. Configuring system settings

   5. Configuring Internet Explorer settings

1.) Pre-File Copy Phase

During this phase, Windows 98 Setup runs ScanDisk on the hard disk, sets up the Windows 98 Setup Wizard, determines the folder in which to install Windows 98, prompts you for your CD Key number, and determines the components to be installed with Windows 98.

Windows 98 Setup first displays the End User License Agreement (EULA). When you accept the EULA, Windows 98 Setup prompts you for your CD Key number. The CD Key number is a twenty-five digit value located on the back of the Windows 98 CD-ROM sleeve.

When you run Windows 98 Setup from within Microsoft Windows 95, Setup automatically installs Windows 98 to the same folder in which Windows 95 is installed. When you run Windows 98 Setup from Windows 3.1 or MS-DOS, you are prompted for the folder in which to install Windows 98.

Windows 98 Setup then runs ScanReg to test the integrity of the registry. ScanReg also makes a backup copy of the registry at this point.

You are then prompted to save system files from the previous operating system. Saving these files enables to uninstall Windows 98. Note that if you convert your hard disk to FAT32, you no longer have the option to uninstall Windows 98.

Windows 98 Setup then determines what components to install based on the following criteria:

If you run Windows 98 Setup from within Windows 95, Windows 98 Setup automatically installs the same components that are installed in Windows 95.

If you run Windows 98 Setup from MS-DOS or from within Windows 3.1, you are prompted to perform a Typical, Portable, Compact, or Custom Setup.

After you select a Setup option, you are prompted for the locale for the Internet channels.

You are then prompted to create a Windows 98 Startup disk. After you create a Windows 98 startup disk, Setup proceeds to the file copy phase.

2.) File Copy Phase

During this phase, Windows 98 Setup copies the files needed to complete Setup. This involves copying files from the Windows 98 CD-ROM or shared network drive to your local hard disk.

3.) Enumeration/Detection Phase

During this phase, Windows 98 Setup determines what hardware components are installed in your computer. This phase requires you to restart your computer either once or twice, depending on the type of hardware in your computer. This Setup phase can be identified by the Setting Up Hardware screen.

4.) Configuring System Settings

During this phase, Windows 98 Setup configures Control Panel, prompts you for the appropriate time zone, and finalizes system settings in preparation for the first time Windows 98 is started.

5.) Configuring Internet Explorer Settings

During this phase, which occurs when Windows 98 Setup restarts for the last time, Internet Explorer configures personal settings and any other optional Internet utilities installed with Windows 98.

Exercise 2: Post Installation tips

1. Adjust Display Resolution.  Right-click the Desktop, select Properties.  Click the Settings tab.  Move the slider to 640x480 and click OK.  After the display readjusts itself, open the Display Properties again, and readjust the display to 800x600.  Click the Advanced Tab under Settings and checkmark "Show settings icon on Taskbar."  When the icon appears in the System Tray portion of the taskbar, click on it, and notice the express shortcut for changing screen resolutions.

2. Add useful programs omitted during Setup.  Open Control Panel->Add/Remove Programs and click on the Windows Setup tab.

3. Hardware Integrity Check  Right-click My Computer icon, choose Properties and click on the Device Manager tab.
4. Create Quick Access Shortcuts  (Start Menu and Desktop)
5. Verify installation/install modem and printer

Optimize Windows Performance Settings:  System Applet, M
Exercise 3: Discover Windows 98 Startup Menu and Boot options

1. Boot to the Windows 98 Startup Menu. Shut down Windows if currently running and choose "Shut Down Windows" from the Shutdown menu.  Turn the computer back on. When the system reboots, hold down the CTRL key before the "Starting Windows 98" message appears on the screen.

2. Choose MS-DOS Command Prompt from the Startup Options.  Switch off the computer after you reach the C-prompt, hold down the CTRL key and reboot into the Startup Menu.  This time, choose Step-by-step boot.

3. After Windows 98 reappears, open My Computer.  Choose View->Folder Options->View and click "Show All Files" in the Hidden Files section.

4. In Windows Explorer or My Computer, go to the C:\ directory, select MSDOS.SYS, right-click and open its file properties. Deselect or confirm that the "read only" and "hidden file" options are deselected. 

5. Open Notepad.  Choose File->Open, select "All Files" in the "Files of All Types" field and open MSDOS.SYS.   Examine the various default settings.  Under [Options] change the BOOTGUI= setting from '1' to '0' and save the file.

6. Shut down Windows 98 and restart.  What happens?  Does the Windows interface load?

From the C-prompt, enter EDIT to open the MS-DOS Editor.  Open the MSDOS.SYS configuration file and restore the default setting of "BOOTGUI=1"

This table describes all of the entries in MSDOS.SYS, with their typical default values.

Production:  Note that the following table contains indented items and special characters.

	Entry
	Description

	[Paths] section:
	

	HostWinBootDrv=c
	Defines the location of the boot drive root directory.

	WinBootDir=
	Defines the location of the necessary startup files. The default is the directory specified during Setup; for example, C:\Windows.

	WinDir=
	Defines the location of the Windows 98 directory as specified during Setup.

	UninstallDir=
	Defines the location of the directory used for uninstall data, to return the computer to a previous operating system

	[Options] section:
	

	Autoscan=
	Controls the automatic launching of ScanDisk after a bad Windows 98 shutdown.  AutoScan=0 disables the running of ScanDisk, AutoScan=1, the default, causes the system to prompt you to run ScanDisk after a bad shutdown.  AutoScan=2 bypasses system prompts and runs ScanDisk automatically.

	BootDelay=n
	Sets the initial startup delay to n seconds. The default is 2. BootKeys=0 disables the delay. The only purpose of the delay is to give the user sufficient time to press F8 after the Starting Windows message appears.

	BootFailSafe= 
	Enables Safe Mode for system startup. The default is 0. (This setting is enabled typically by equipment manufacturers for installation.)

	BootGUI=
	Enables automatic graphical startup into Windows 95. The default is 1.

	BootKeys=
	Enables the startup option keys (that is, CTRL, F5, F6, and F8). The default is 1. Setting this value to 0 overrides the value of BootDelay=n and prevents any startup keys from functioning. This setting allows system administrators to configure more secure systems

	BootMenu=
	Enables automatic display of the Windows 98 Startup menu, so that the user must press F8 to see the menu. The default is 0. Setting this value to 1 eliminates the need to press F8 to see the menu. 

	BootMenuDefault=#
	Sets the default menu item on the Windows Startup menu; the default is 3 for a computer with no networking components, and 4 for a networked computer.

	BootMenuDelay=#
	Sets the number of seconds to display the Windows Startup menu before running the default menu item. The default is 30.

	BootMulti=
	Enables dual boot capabilities. The default is 0. Setting this value to 1 enables the ability to start DOS by pressing F4 or by pressing F8 to use the Windows Startup menu.

	BootWarn=
	Enables the Safe Mode startup warning. The default is 1.

	BootWin=
	Enables Windows 95 as the default operating system. Setting this value to 0 disables Windows 95 as the default; this is useful only with DOS version 5 or 6.x on the computer. The default is 1.

	DblSpace=
	Enables automatic loading of Dblspace.bin. The default is 1.

	DoubleBuffer=
	Enables loading of a double-buffering driver for a SCSI controller. The default is 0. Setting this value to 1 enables double-buffering, if required by the SCSI controller.

	DrvSpace=
	Enables automatic loading of Drvspace.bin. The default is 1.

	LoadTop=
	Enables loading of Command.com or Drvspace.bin at the top of 640K memory. The default is 1. Set this value to 0 with Novell® NetWare® or any software that makes assumptions about what is used in specific memory areas.

	Logo=
	Enables display of the animated logo. The default is 1. Setting this value to 0 also avoids hooking a variety of interrupts that can create incompatibilities with certain memory managers from other vendors.

	Network=
	Enables Safe Mode With Networking as a menu option. The default is 1 for computers with networking installed. This value should be 0 if network software components are not installed. 

	Winver=
	Designates the version and build number of the Windows operating system installed on the host drive.


