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Menambah Interaktivitas Macro 
 

 

Macro yang Anda buat tentu akan lebih menarik jika dapat 
berinteraksi dengan pengguna. Untuk keperluan tersebut, Anda 
dapat membuat kotak pesan, kotak input, kotak dialog atau 
ActiveX Control. Pemilihan salah satu model yang digunakan akan 
sangat tergantung pada kebutuhan. Macro yang hanya digunakan 
untuk membuat worksheet akan lebih tepat jika ditambahkan 
interaktivitas menggunakan kotak pesan. Selain lebih mudah, 
pembuatan kotak pesan juga tidak memakan banyak waktu.  
Namun, apabila Macro yang Anda buat membutuhkan kontrol 
yang tidak tersedia dalam kotak pesan atau kotak input (misalnya 
Frame, ComboBox, ListBox), Anda disarankan untuk membuat 
kotak dialog menggunakan UserForm. 

2.1 Kotak Pesan (Message Box) 
Kotak pesan digunakan untuk menampilkan pesan kepada 
pengguna. Pesan tersebut dapat berupa pesan kritis, pesan 
informasi, pesan peringatan atau pesan pertanyaan. Dengan 
menggunakan kotak pesan, Anda dapat memberitahukan kepada 
pengguna mengenai apa yang akan dijalankan oleh Macro dan 
selanjutnya memberikan pilihan kepada pengguna untuk tetap 
melanjutkan atau tidak. Contoh lain penggunaan kotak pesan 
adalah untuk memberi peringatan kepada pengguna bahwa terjadi 
kesalahan dan memberitahukan tindakan apa yang perlu dila-
kukan untuk mengatasi kesalahan tersebut.   

Anda perlu mengetahui aturan pembuatan kotak pesan sehingga 
pesan yang disampaikan dapat dipahami oleh pengguna dengan 
gamblang. Apabila pesan yang ingin Anda sampaikan adalah 
pesan yang bersifat pertanyaan, akan lebih tepat jika ikon yang 
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digunakan adalah ikon pertanyaan (vbQuestion). Kode Macro untuk 
membuat kotak pesan ditulis dengan format sebagai berikut: 
MsgBox([prompt], [buttons], [title], [helpfile], [context]) 
 

 [prompt] merupakan pesan yang akan disampaikan kepada 
pengguna. Argumen prompt merupakan argumen yang 
diperlukan pada kotak pesan sehingga harus diisi. Panjang 
pesan maksimal 1024 karakter. Apabila Anda ingin membuat 
pesan lebih dari 1 baris, pisahkan baris menggunakan kode 
vbCrLf.   

 [buttons] merupakan argumen untuk memilih jenis tombol, 
memilih jenis ikon, memilih tombol default dan memilih jenis 
modal kotak pesan. Argumen buttons bersifat opsional 
sehingga dapat diisi ataupun tidak diisi. Apabila tidak diisi, 
kotak pesan secara default hanya menampilkan tombol OK.   

Jenis tombol yang dapat ditambahkan pada kotak pesan 
menggunakan VBA adalah sebagai berikut. 

Jenis tombol  Nilai  Keterangan 

vbOKOnly  0  Tombol OK 

vbOKCancel  1  Tombol OK dan Cancel 

vbAbortRetryIgnore  2  Tombol Abort, Retry dan Ignore 

vbYesNoCancel  3  Tombol Yes, No dan Cancel 

vbYesNo  4  Tombol Yes dan No 

vbRetryCancel  5  Tombol Retry dan Cancel 
 

Jenis ikon yang dapat dibuat pada kotak pesan menggunakan 
VBA adalah sebagai berikut. 

Jenis ikon  Ikon  Nilai  Keterangan 

vbCritical    16  Ikon pesan kritis 

vbQuestion    32  Ikon pertanyaan 

vbExclamation    48  Ikon peringatan 

vbInformation    64  Ikon informasi 
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Tombol default adalah tombol kotak pesan yang dipilih saat 
pengguna menekan tombol Enter pada keyboard. Pilihan 
tombol default kotak pesan VBA adalah sebagai berikut. 

Tombol default  Nilai  Keterangan 

vbDefaultButton1  0  Tombol pertama sebagai default 

vbDefaultButton2  256  Tombol kedua sebagai default 

vbDefaultButton3  512  Tombol ketiga sebagai default 
 
 

Jenis modal kotak pesan berfungsi untuk mengatur tampilan 
kotak pesan, apakah hanya ditampilkan saat Excel aktif atau 
akan tetap ditampilkan walaupun Excel tidak aktif. Secara 
default, kotak pesan ditampilkan dengan jenis Modal 
Application. Pilihan jenis modal kotak pesan VBA adalah 
sebagai berikut. 

Jenis modal  Nilai  Keterangan 

vbApplicationModal  4096 
Kotak pesan yang hanya ditampilkan 
saat Excel aktif 

vbSystemModal  16384 
Kotak pesan ditampilkan tidak hanya 
saat Excel aktif 

 
 
 

  [title] merupakan judul kotak pesan. Argumen title bersifat 
opsional sehingga dapat diisi ataupun tidak diisi. Apabila tidak 
diisi, secara default judul kotak pesan adalah Microsoft Excel. 

 [help] dan [context] merupakan fasilitas bantu VBA yang akan 
ditampilkan apabila pengguna menekan tombol F1 pada 
Keyboard. Argumen help dan context harus digunakan secara 
bersamaan. 

2.1.1 Membuat Kotak Pesan  
Dalam contoh kali ini kita akan membuat kotak pesan yang 
menampilkan informasi biodata penulis. Sesuai dengan tujuannya, 
ikon yang ditampilkan kotak pesan yang sesuai ialah ikon 
informasi dengan tombol OK. 

1. Tekan kombinasi tombol Ctrl+N untuk membuat workbook 
baru. Simpan workbook dengan nama Membuat Kotak 
Pesan.xlsm. 
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2. Tekan kombinasi tombol Alt+F11 atau klik tombol Visual 
Basic dalam tab Developer group Code untuk membuka Visual 
Basic Editor. 

3. Pada jendela Visual Basic Editor, pilih menu Insert > Module.  
Ketikkan kode Macro berikut pada window Code Module1:. 

Sub KotakPesan() 
 
MsgBox "Yudhy Wicaksono" & vbCrLf & _ 
    "Website: www.solusi-macro.com" & vbCrLf & _ 
    "e-mail: yudhy_wicaksono2000@yahoo.com", _ 
    vbOKOnly + vbInformation, _ 
    "Penulis Buku Ini" 
 
End Sub 
 

 
4. Kembali ke program utama Excel. Tekan kombinasi tombol 

Alt+F8 atau klik tombol Macros dalam tab Developer group 
Code untuk menampilkan kotak dialog Macro.   

 

Gambar 2.1 Kotak dialog Macro. 

5. Pilih Macro KotakPesan kemudian klik tombol Run. Setelah 
Macro dijalankan, muncul kotak pesan Penulis Buku Ini. 

 

Gambar 2.2 Tampilan kotak pesan informasi yang dibuat. 
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2.1.2 Nilai Kotak Pesan 
Anda dapat membuat kotak pesan yang ketika direspons (dipilih 
tombol tertentu) akan mengembalikan nilai yang digunakan untuk 
menentukan kejadian yang akan dilakukan. Misalnya, Anda dapat 
membuat kotak pesan untuk memperingatkan kepada pengguna 
bahwa Macro yang dijalankan akan menghapus seluruh data 
dalam worksheet aktif. Apabila tombol OK diklik, seluruh data 
akan terhapus. Namun, jika tombol Cancel yang diklik, data tidak 
jadi dihapus. Kode Macro untuk membuat kotak pesan yang 
mengembalikan nilai ditulis dengan format berikut: 
Nilai = MsgBox([prompt], [buttons], [title]) 
 
 
Daftar konstanta dan nilai tombol kotak pesan dapat dilihat pada 
tabel. Anda dapat memilih apakah akan menggunakan konstanta 
atau nilai untuk merespons tombol yang diklik pengguna. 

Konstanta  Nilai  Tombol yang dipilih 

vbOK  1  OK 

vbCancel  2  Cancel 

vbAbort  3  Abort 

vbRetry  4  Retry 

vbIgnore  5  Ignore 

vbYes  6  Yes 

vbNo  7  No 
 
1. Tekan kombinasi tombol Ctrl+N untuk membuat workbook 

baru. Simpan workbook dengan nama Nilai Kotak Pesan.xlsm. 

2. Untuk membuka Visual Basic Editor, tekan kombinasi tombol 
Alt+F11 pada keyboard atau klik tombol Visual Basic dalam 
tab Developer group Code. 

3. Pada jendela Visual Basic Editor pilih menu Insert > Module.  
Ketikkan kode Macro berikut pada window Code Module1:. 

Sub NilaiKotakPesan() 
 
'Kotak pesan 
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Hapus = MsgBox("Macro akan menghapus data", _ 
    vbOKCancel + vbExclamation + vbDefaultButton2, _ 
    "Hapus Data") 
 
'Apabila tombol OK diklik 
If Hapus = vbOK Then 
    'Menghapus seluruh data dalam worksheet aktif 
    Cells.ClearContents 
'Apabila tombol Cancel diklik 
ElseIf Hapus = vbCancel Then 
    'Kotak pesan "Data tidak jadi dihapus" 
    MsgBox "Data tidak jadi dihapus", vbInformation 
End If 
 
'Seleksi sel A1 
Range("A1").Select 
 
End Sub 
 

 
4. Kembali ke program utama Excel. Untuk menguji hasilnya, 

ketikkan sembarang nilai pada sel A1 dan C5, misalnya, 
ketikkan 12 pada sel A1 dan 184 pada sel C5. 

5. Tekan kombinasi tombol Alt+F8 atau klik tombol Macros 
dalam tab Developer group Code untuk menampilkan kotak 
dialog Macro. 

6. Pilih Macro NilaiKotakPesan kemudian klik tombol Run. 
Setelah Macro dijalankan, muncul kotak pesan Hapus Data. 

 

Gambar 2.3 Kotak pesan peringatan Hapus Data. 

7. Jika tombol OK yang diklik, seluruh data dalam worksheet aktif 
akan terhapus, lihat sel A1 dan C5. Apabila tombol Cancel 
yang diklik, muncul kotak pesan seperti pada Gambar 2.4.  
Jika Anda menekan tombol Enter pada keyboard, maka yang 
akan dijalankan adalah tombol Cancel karena yang digunakan 
sebagai default adalah tombol kedua. 
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Gambar 2.4 Data tidak jadi dihapus.  

2.2 Kotak Input (Input Box) 
Kotak input pada dasarnya memiliki kegunaan yang sama dengan 
kotak pesan, yaitu untuk mendapatkan nilai dari pengguna.  
Perbedaan kotak pesan dan kotak input terletak dari cara yang 
dilakukan untuk mendapatkan nilai dari pengguna. Untuk men-
dapatkan nilai dari pengguna, kotak pesan menggunakan tombol, 
misalnya tombol OK, tombol Cancel atau tombol lain yang 
disediakan VBA. Kotak input mendapatkan nilai dari pengguna 
setelah pengguna memasukkan nilai pada kotak isian dalam kotak 
input. 

Seperti halnya dalam membuat kotak pesan, Anda juga perlu 
mengetahui aturan penulisan untuk membuat kotak input. Format 
kode Macro untuk membuat kotak input adalah sebagai berikut: 
InputBox([prompt], [title], [default], [type]) 
 
 

 [prompt] merupakan informasi yang disampaikan kepada 
pengguna. Argumen prompt merupakan argumen yang 
diperlukan pada kotak input sehingga harus diisi. 

 [title] merupakan judul kotak input. Argumen title bersifat 
opsional sehingga dapat diisi ataupun tidak. Apabila tidak diisi, 
secara default judul kotak input adalah Microsoft Excel. 

 [default] merupakan nilai default pada kotak input. Argumen 
default bersifat opsional sehingga dapat diisi ataupun tidak. 

 [type] merupakan tipe kotak input. Berikut pilihan tipe kotak 
input yang disediakan VBA. 
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Nilai  Tipe kotak input 

0  Formula 

1  Angka 

2  Teks 

4  Nilai logika (True atau False) 

8  Sel atau range 

16  Nilai error 

64  Nilai array 

 

Pada latihan ini kita akan membuat kotak input berat badan 
pengguna. Berat badan yang diisikan pengguna akan ditampilkan 
pada kotak pesan serta dimasukkan ke dalam sel A1 worksheet 
aktif. 

1. Tekan kombinasi tombol Ctrl+N untuk membuat workbook 
baru. Simpan workbook dengan nama Membuat Kotak 
Input.xlsm.   

2. Tekan kombinasi tombol Alt+F11 atau klik tombol Visual 
Basic dalam tab Developer group Code untuk membuka Visual 
Basic Editor. 

3. Pada jendela Visual Basic Editor pilih menu Insert > Module.  
Ketikkan kode Macro berikut pada window Code Module1:. 

Sub KotakInput() 
 
'Kotak input 
Berat = InputBox("Berapa berat badan Anda?" _ 
    & vbCrLf & "Dalam kg", "Berat Badan", 50) 
 
'Jika kotak input kosong atau tombol Cancel diklik 
If Berat = "" Or Berat = "Boolean" Then 
    'Keluar dari Sub Prosedure 
    Exit Sub 
End If 
 
'Menampilkan kotak pesan Berat Badan 
MsgBox "Berat badan Anda adalah " & Berat & _ 
    " kilogram", vbOKOnly, "Berat Badan" 
 
'Memasukkan nilai kotak input ke dalam sel A1 
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Range("A1").Value = Berat 
 
End Sub 
 

 
4. Kembali ke program utama Excel. Tekan kombinasi tombol 

Alt+F8 atau klik tombol Macros dalam tab Developer group 
Code untuk menampilkan kotak dialog Macro.  

5. Pilih Macro KotakInput kemudian klik tombol Run. Setelah 
Macro dijalankan, muncul kotak input Berat Badan. 

 

Gambar 2.5 Kotak input Berat Badan. 

6. Secara default nilai kotak input adalah 50. Anda dapat 
mengubah nilai tersebut sesuai keinginan. Misalnya berat badan 
Anda 65 kilogram, ketikkan nilai tersebut pada kotak input.  
Klik tombol OK. Data yang Anda masukkan kemudian ditam-
pilkan pada kotak pesan Berat Badan. 

 

Gambar 2.6 Kotak pesan Berat Badan.  

7. Klik tombol OK. Selain ditampilkan kotak pesan, data berat 
badan juga dimasukkan ke dalam sel A1 worksheet aktif.  

2.3 Built In Kotak Dialog 
Salah satu kemudahan dalam menggunakan Macro Excel adalah 
tersedianya banyak built in kotak dialog (kotak dialog siap pakai).  
Misalnya, Anda dapat menggunakan kotak dialog Format Cells: 
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Font Properties untuk mengatur format font. Anda dapat me-
manfaatkan fasilitas Auto List Members untuk menampilkan daftar 
built in kotak dialog. 

 

Gambar 2.7 Daftar built in kotak dialog. 

1. Buka file Built In Kotak Dialog.xlsm yang disertakan dalam CD 
pendamping buku. 

2. Tekan kombinasi tombol Alt+F11 atau klik tombol Visual 
Basic dalam tab Developer group Code untuk membuka Visual 
Basic Editor.   

3. Pada jendela Visual Basic Editor, pilih menu Insert > Module.  
Ketikkan kode Macro berikut pada window Code Module1: 

Sub BuiltInKotakDialog() 
 
'Built in kotak dialog Format Cells: Font Properties 
Application.Dialogs(xlDialogFontProperties).Show 
 
End Sub 
 

 
4. Kembali ke program utama Excel. Blok range A3:D10. Tekan 

kombinasi Alt+F8 atau klik tombol Macros dalam tab 
Developer group Code untuk menampilkan kotak dialog Macro.  

5. Pilih Macro BuiltInKotakDialog kemudian klik tombol Run. 
Muncul kotak dialog Format Cells: Font Properties. 
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Gambar 2.8 Kotak dialog Format Cells: Font Properties. 

6. Pada daftar pilihan Font: pilih Tahoma. Pada daftar pilihan Font 
style: pilih Italic. Pilih 10 pada daftar pilihan Size:. Klik tombol 
OK. Format font range A3:D10 yang terseleksi kemudian 
berubah menyesuaikan hasil pengaturan melalui kotak dialog. 

 

2.4 UserForm 
UserForm merupakan tempat penampung objek kontrol. Anda 
dapat menggunakan UserForm untuk membuat kotak dialog.  
Untuk menambahkan UserForm, pilih menu Insert > UserForm 
pada Visual Basic Editor.  

 

Gambar 2.9 Tampilan UserForm. 
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Pengaturan UserForm secara visual, misalnya mengubah ukuran 
UserForm, menambahkan kontrol, mengatur posisi kontrol dan 
pengaturan lainnya, dapat dilakukan melalui window Object.  
Pengaturan yang lebih detail dilakukan melalui window Properties. 

2.4.1 ToolBox 
Toolbox merupakan tempat kontrol yang dapat dipilih untuk 
kemudian ditambahkan ke dalam UserForm. Untuk menampilkan 
window Toolbox klik tombol Toolbox ( ) pada toolbar Standar, 
atau pilih menu utama View > Toolbox. 

 

Gambar 2.10 Tampilan Toolbox. 

Berikut nama kontrol beserta fungsi kontrol yang secara default 
ada dalam Toolbox. 

Kontrol  Gambar  Fungsi 

Select Objects   

Untuk  memilih  objek  kontrol  pada 
Toolbox,  menempatkan  kontrol  pada 
UserForm,  mengubah  ukuran  kontrol 
dan  memindah  posisi  kontrol  dalam 
UserForm. 

Label   

Untuk  membuat  teks  berupa  informasi 
singkat  kepada  pengguna.  Teks  yang 
ditampilkan  tidak  dapat  diubah  peng‐
guna pada saat UserForm dijalankan.    

TextBox   
Untuk  membuat  kotak  isian  pada 
UserForm. Pengguna dapat memasukkan 
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nilai  (dapat berupa angka ataupun  teks) 
ke dalam kotak isian.   

ComboBox   

Untuk menampilkan  daftar  pilihan  yang 
dikelompokkan  dalam  TextBox.  Peng‐
guna  juga  dapat  mengetik  pilihannya 
dalam  ComboBox,  namun  hal  tersebut 
tergantung pada style yang digunakan. 

ListBox   

Untuk  menampilkan  pilihan  yang  dike‐
lompokkan dalam sebuah daftar pilihan, 
yang dapat digeser secara vertikal. 

CheckBox   
Untuk  menampilkan  beberapa  pilihan 
yang dapat dipilih lebih dari satu. 

OptionButton   

Untuk  menampilkan  beberapa  pilihan 
yang  hanya  dapat  dipilih  salah  satu 
dalam suatu UserForm atau Frame. 

ToggleButton   
Untuk membuat pilihan  tombol on atau 
off pada UserForm. 

Frame   
Untuk  mengelompokkan  kontrol  yang 
mempunyai fungsi sama. 

CommandButton   

Untuk  membuat  tombol  yang  akan 
menjalankan  suatu  perintah  apabila 
tombol tersebut ditekan. 

TabStrip   
Untuk membuat  beberapa  kotak  dialog 
pada UserForm.  

MultiPage   
Untuk  membuat  satu  pengelompokan 
kontrol atau lebih dalam satu tampilan. 

ScrollBar   

Untuk  melakukan  pemasukan  data  se‐
cara  analog,  yaitu  dengan  melakukan 
penggeseran  pada  bidang  ScrollBar 
ataupun  penekanan  pada  tombol  (atas, 
bawah, kiri atau kanan). 

SpinButton   
Untuk menunjukkan nilai yang berurutan 
dengan range yang konsisten. 

Image    Untuk  menampilkan  gambar  dalam 
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format  bitmaps  (*.bmp,  *.dib),  GIF 
(*.gif),  JPEG  (*.jpeg),  Metafiles  (*.wmf, 
*.emf) dan Icons (*.ico, *.cur). 

RefEdit   
Untuk mengedit  alamat  reference  pada 
Microsoft Excel. 

 

2.4.2 Menambahkan Kontrol 
Sebelum menambahkan kontrol, Anda tentu harus menyiapkan 
UserForm yang akan dijadikan sebagai tempat penampung kontrol 
terlebih dahulu.   

1. Tekan kombinasi tombol Alt+F11 atau klik tombol Visual 
Basic dalam tab Developer group Code untuk menjalankan 
Visual Basic Editor.   

2. Pilih menu Insert > UserForm untuk menambahkan UserForm.  
Ketika menambahkan UserForm, secara otomatis Toolbox akan 
ditampilkan. Jika belum ditampilkan, pilih menu View > 
Toolbox. 

 

Gambar 2.11 Memilih kontrol yang akan ditambahkan. 

3. Klik kontrol yang akan ditambahkan ke dalam UserForm, 
dalam contoh kali ini pilih TextBox. Klik mouse pada bidang 
UserForm untuk menambahkan kontrol ke dalam UserForm. 
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Gambar 2.12 Menambahkan kontrol ke dalam UserForm. 

2.4.3 Mengubah Ukuran dan Posisi Kontrol 
Saat pertama kali dibuat, ukuran dan posisi kontrol mungkin tidak 
sesuai dengan yang kita harapkan. Ukuran dan posisi kontrol 
dapat diubah menggunakan mouse melalui window Properties atau 
melalui kode Macro. Berikut langkah-langkah untuk mengubah 
ukuran dan posisi kontrol menggunakan mouse: 

1. Klik kontrol yang akan diubah ukurannya. Arahkan pointer 
pada titik yang terdapat di bagian tengah garis kontrol. Ketika 
mouse siap digunakan untuk mengubah lebar kontrol bentuk 
kursor mouse akan menjadi . Mouse yang siap digunakan 
untuk mengubah tinggi kontrol bentuk kursornya akan berubah 
menjadi .   

2. Klik dan tahan mouse saat siap digunakan untuk mengubah 
ukuran kontrol. Tarik titik ke bagian dalam untuk memperkecil 
ukuran kontrol, atau tarik ke bagian luar untuk memperbesar 
ukuran kontrol. 

 

Gambar 2.13 Mengubah ukuran kontrol menggunakan mouse. 
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3. Untuk mengubah posisi kontrol, klik dan tahan mouse pada 
bidang kontrol kemudian tarik pada posisi yang diinginkan. 
Jika posisi sudah sesuai, lepaskan tombol mouse. 

 

Gambar 2.14 Mengubah posisi kontrol menggunakan mouse. 

2.4.4 Menyalin Kontrol 
Untuk menambahkan banyak kontrol yang sama, Anda dapat 
melakukannya secara cepat dengan cara menyalin kontrol.  
Teknik menyalin kontrol dapat dilakukan dengan dua cara, yaitu 
dengan teknik copy paste dan teknik drag and drop. 

1. Untuk menyalin kontrol dengan teknik copy paste pilih kontrol 
yang akan disalin menggunakan klik mouse. 

2. Tekan kombinasi tombol Ctrl+C atau pilih menu Edit > Copy.  
Untuk menyalin kontrol, tekan kombinasi tombol Ctrl+V atau 
pilih menu Edit > Paste. 

 

Gambar 2.15 Menyalin kontrol dengan teknik copy paste. 
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3. Untuk menyalin kontrol dengan teknik drag and drop tekan dan 
tahan tombol Ctrl pada keyboard. Klik dan tahan tombol kiri 
mouse kemudian tarik mouse pada posisi yang diinginkan. Saat 
menyalin kontrol, pointer mouse akan menampilkan tanda plus 
(+). Jika posisi kontrol sudah sesuai, lepaskan tombol mouse. 

 

Gambar 2.16 Menyalin kontrol dengan teknik drag and drop. 

2.4.5 Menghapus Kontrol 
Kontrol yang sudah tidak digunakan sebaiknya Anda hapus agar 
tidak membingungkan pengguna. Pilih kontrol yang akan dihapus 
kemudian tekan tombol Delete pada keyboard atau pilih menu 
Edit > Delete. Anda juga dapat menghapus kontrol melalui menu 
klik kanan. Klik kanan kontrol yang akan dihapus kemudian pilih 
menu Delete. 

 

Gambar 2.17 Menghapus kontrol melalui menu klik kanan. 

2.4.6 Membuat Kotak Dialog 
Pada pembahasan kali ini kita akan membuat kotak dialog yang 
digunakan untuk membuat worksheet baru pada workbook aktif.  
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Melalui kotak dialog, kita dapat memilih akan membuat worksheet 
dengan nama default atau dengan nama yang kita tentukan. 

1. Tekan kombinasi tombol Ctrl+N untuk membuat workbook 
baru. Simpan workbook dengan nama Membuat Kotak 
Dialog.xlsm. 

2. Tekan kombinasi tombol Alt+F11 atau klik tombol Visual 
Basic dalam tab Developer group Code untuk membuka Visual 
Basic Editor. 

3. Pada jendela Visual Basic Editor, pilih menu utama Insert > 
UserForm. Atur properti UserForm melalui window Properties.   

4. Pilih menu utama View > Properties Window, atau tekan 
tombol F4. Ubah properti UserForm sebagai berikut: Name = 
BuatWorksheet, Caption = Buat Worksheet, Height = 126, 
Width = 201. 

 

Gambar 2.18 Mengubah properti UserForm. 

5. Pilih kontrol Frame pada Toolbox kemudian klik mouse pada 
bidang UserForm. Langkah tersebut dilakukan untuk menam-
bah kontrol Frame pada UserForm. Ubah properti kontrol 
Frame menjadi Name = frmNama, Caption = Nama worksheet, 
Height = 60, Left = 6, Top = 6, Width = 180.   
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Gambar 2.19 Menambahkan kontrol Frame. 

6. Dengan cara yang sama, tambahkan kontrol lainnya pada 
UserForm, sehingga tampilan UserForm menjadi seperti pada 
Gambar 2.20. 

 

Gambar 2.20 Tampilan UserForm. 

7. Pengaturan setting properti pada UserForm dan objek kontrol 
selengkapnya sebagai berikut: 

Objek  Setting Properti 

UserForm 
Name = BuatWorksheet, Caption = Buat Worksheet, 
Height = 126, Width = 201 

Frame 
Name  =  frmNama,  Caption  =  Nama  worksheet, 
Height = 60, Left = 6, Top = 6, Width = 180 

OptionButton 
Name  = optDefault, Caption = Default, Height = 18, 
Left = 6, Top = 6, Width = 45, Value = True 

OptionButton 
Name   = optUbah, Caption = Ubah  :, Height = 18, 
Left = 6, Top = 30, Width = 45 
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TextBox 
Name  = txtNama, Locked = True, Height = 18, Left = 
54, Top = 30, Width = 120 

CommandButton 
Name   = cmdOK, Caption = OK, Height = 24, Left = 
132, Top = 72, Width = 54 

CommandButton 
Name    =  cmdBatal,  Caption  =  Batal,  Height  =  24, 
Left = 72, Top = 72, Width = 54 

 
8. Untuk mementukan urutan pilihan dari satu kontrol ke kontrol 

lain menggunakan tombol Tab pada keyboard (Tab Order), klik 
kanan bidang UserForm kemudian pilih menu Tab Order. 

 

Gambar 2.21 Memilih menu klik kanan Tab Order. 

9. Muncul kotak dialog Tab Order. Untuk menentukan urutan 
kontrol, klik tombol Move Up atau Move Down. Atur urutan 
objek hingga terlihat seperti Gambar 2.22. Jika sudah, klik 
tombol OK. 

 

Gambar 2.22 Tab Order UserForm. 

10. Untuk mementukan urutan Tab Order pada frame Nama 
worksheet, klik kanan bidang frame Nama worksheet lalu pilih 
menu Tab Order. Muncul kotak dialog Tab Order.  
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11. Atur urutan objek pada frame Nama worksheet hingga terlihat 
seperti Gambar 2.23. Jika sudah, klik tombol OK. 

 

Gambar 2.23 Tab Order frame Nama worksheet. 

12. Pilih menu View > Code atau tekan F7. Ketikkan kode Macro 
sebagai berikut: 

'Kode saat opsi Default dipilih 
Private Sub optDefault_Click() 
 
'TextBox Nama terkunci 
txtNama.Locked = True 
 
End Sub 
 
'Kode saat opsi Ubah dipilih 
Private Sub optUbah_Click() 
 
'TextBox Nama tidak terkunci 
txtNama.Locked = False 
 
End Sub 
 
'Kode apabila tombol OK ditekan 
Private Sub cmdOK_Click() 
 
'Lanjutkan Macro jika terjadi error 
On Error Resume Next 
 
'Membuat worksheet baru 
Set NewSheet = Application.Sheets.Add 
 
'Jika opsi Default dalam keadaan terpilih 
If optDefault.Value = True Then 
    'Keluar dari Sub Prosedur 
    Exit Sub 
'Jika opsi Ubah dalam keadaan terpilih 
ElseIf optUbah.Value = True Then 
    'Jika nama worksheet yang ditulis belum ada 
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    If Application.Sheets(txtNama.Text) Is Nothing Then 
        'Memberi nama worksheet 
        NewSheet.Name = txtNama.Text 
        'Menonaktifkan kotak dialog 
        Unload Me 
    Else 
        'Menonaktifkan kotak dialog 
        Unload Me 
        'Kotak pesan jika nama worksheet sudah ada 
        MsgBox "Nama worksheet sudah ada", _ 
            vbOKOnly + vbInformation 
    End If 
End If 
 
End Sub 
 
'Kode saat tombol Batal ditekan 
Private Sub cmdBatal_Click() 
 
'Menonaktifkan kotak dialog 
Unload Me 
 
End Sub 
 

 
13. Agar kotak dialog dapat dijalankan melalui Excel, tambahkan 

modul dengan memilih menu utama Insert > Module.  
Ketikkan kode Macro pada Module1 sebagai berikut: 
Sub LoadBuatWorksheet() 
 
'Mengaktifkan kotak dialog 
Load BuatWorksheet 
 
'Menampilkan kotak dialog 
BuatWorksheet.Show 
 
End Sub 
 

 
14. Kembali ke program utama Excel. Tekan kombinasi tombol 

Alt+F8 atau klik tombol Macros dalam tab Developer group 
Code untuk menampilkan kotak dialog Macro. 

15. Pilih Macro LoadBuatWorksheet kemudian klik tombol Run.  
Muncul kotak dialog Buat Worksheet. 

16. Pilih opsi Ubah untuk membuat worksheet baru dengan nama 
yang kita tentukan. Ketikkan nama worksheet pada kotak isian 
yang tersedia kemudian klik tombol OK.   
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Gambar 2.24 Kotak dialog Buat Worksheet. 

17. Jika nama worksheet sudah ada, nama workshet secara 
default mempunyai format SheetN dan muncul kotak pesan 
seperti terlihat pada Gambar 2.25.   

 

Gambar 2.25 Nama worksheet sudah ada. 

2.4.7 Ekspor Kotak Dialog 
Anda dapat mengekspor kotak dialog (UserForm) yang telah 
dibuat. Kotak dialog tersebut kemudian dapat Anda gunakan 
kembali saat dibutuhkan untuk proyek Anda yang lain. File yang 
digunakan dalam pembahasan kali ini adalah file hasil latihan 
sebelumnya, Membuat Kotak Dialog.xlsm. 

1. Buka file Membuat kotak dialog.xlsm yang disertakan dalam 
CD pendamping buku.  

2. Tekan kombinasi tombol Alt+F11 atau klik tombol Visual 
Basic dalam tab Developer group Code untuk membuka Visual 
Basic Editor. 

3. Pada Project Explorer klik kanan UserForm BuatWorksheet.  
Muncul daftar menu seperti terlihat pada Gambar 2.26.  
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Gambar 2.26 Tampilan menu klik kanan. 

3. Pilih menu Export File… Muncul kotak dialog Export File 
seperti terlihat pada Gambar 2.27.   

 

Gambar 2.27 Kotak dialog Export File. 

4. Pastikan pilihan pada kotak combo Saves of type: adalah Form 
Files (*.frm). Ketikkan nama file pada kotak isian File name:. 
Jika sudah, klik tombol Save. 
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2.4.8 Impor Kotak Dialog 
Setelah Anda mengekspor kotak dialog, Anda dapat meng-
gunakan kotak dialog tersebut untuk digunakan pada proyek 
(workbook) yang lain, dengan cara mengimpor file kotak dialog. 

1. Tekan kombinasi tombol Ctrl+N untuk membuat workbook 
baru. Simpan workbook dengan nama Impor Kotak 
Dialog.xlsm. 

2. Tekan kombinasi tombol Alt+F11 atau klik tombol Visual 
Basic dalam tab Developer group Code untuk membuka Visual 
Basic Editor. 

3. Klik kanan pada sembarang objek dalam Project Explorer.  
Muncul daftar menu seperti terlihat pada Gambar 2.26. 

4. Pilih menu Import File… Muncul kotak dialog Import File. Pilih 
file BuatWorksheet.frm hasil ekspor (ada dalam CD pendam-
ping buku). Klik tombol Open.   

 

Gambar 2.28 Kotak dialog Import File. 

5. Apabila impor kotak dialog berhasil, pada Project Explorer 
sekarang terdapat UserForm BuatWorksheet. 
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Gambar 2.29 Impor kotak dialog berhasil. 

6. Agar kotak dialog dapat dijalankan melalui Excel, tambahkan 
modul dengan memilih menu utama Insert > Module. Ketikkan 
kode Macro pada Module1 sebagai berikut: 

Sub LoadBuatWorksheet() 
 
'Mengaktifkan kotak dialog 
Load BuatWorksheet 
 
'Menampilkan kotak dialog 
BuatWorksheet.Show 
 
End Sub 
 

 
7. Kembali ke program utama Excel. Tekan kombinasi tombol 

Alt+F8 atau klik tombol Macros dalam tab Developer group 
Code untuk menampilkan kotak dialog Macro. 

8. Pilih Macro LoadBuatWorksheet kemudian klik tombol Run.  
Jika semuanya dijalankan dengan benar, muncul kotak dialog 
Buat Worksheet. 

2.5 ActiveX Controls 
ActiveX Controls merupakan kumpulan kontrol yang ditempatkan 
pada worksheet untuk menambah interaktivitas Macro. ActiveX 
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Control pada dasarnya mempunyai fungsi yang sama dengan 
kontrol dalam Toolbox - Visual Basic Editor. Perbedaannya adalah 
kontrol dalam ActiveX Control ditempatkan pada worksheet, 
sedangkan kontrol dalam Toolbox ditempatkan pada UserForm. 
Perbedaan penempatan kontrol akan sangat terasa ketika Anda 
bekerja dengan lebih dari satu workbook dalam waktu bersamaan. 
Ketika mengunakan kontrol yang ditempatkan dalam UserForm, 
secara default Anda tidak dapat membuka workbook yang lain 
dalam waktu bersamaan. Seluruh kontrol standar dalam ActiveX 
Controls pada prinsipnya sama dengan kontrol yang ditempatkan 
pada UserForm. Pengaturan ActiveX Controls dilakukan melalui 
kontrol dalam tab Developer group Controls. 

 

Gambar 2.30 Tab Developer group Controls. 

Kontrol  Gambar  Fungsi 

Insert 

 

Untuk menambahkan ActiveX Controls ke 
dalam worksheet. 

Design Mode 

 

Untuk memilih kontrol yang sudah ditem‐
patkan  dalam  worksheet,  mengubah 
ukuran  kontrol, memindah  posisi  kontrol 
dan mengubah properti kontrol. 

Properties   

Untuk  menampilkan  window  Properties, 
untuk  mengatur  properti  kontrol  yang 
sedang aktif. 

View Code   

Untuk  menampilkan  kode  Macro  pada 
kontrol yang sedang aktif, melalui window 
Code.  
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2.5.1 Pengaturan Keamanan ActiveX Controls 
Seperti halnya Macro, ActiveX Control juga dapat disalahgunakan 
pengguna yang tidak bertanggung jawab untuk melakukan tin-
dakan yang merugikan. Untuk mengatasi masalah tersebut, Excel 
menyediakan pilihan pengaturan keamanan ActiveX Controls.   

1. Klik tombol Macro Security dalam tab Developer group Code.  
Muncul kotak dialog Trust Center. 

 

Gambar 2.31 Kotak dialog Trust Center. 

2. Pilih opsi ActiveX Settings. Pilih salah satu dari beberapa opsi 
yang disediakan sebagai berikut: 

 Disable all controls without notification. Apabila opsi ini 
dipilih, ActiveX Controls dalam workbook tidak akan 
diaktifkan. 

 Prompt me before enabling Unsafe for Initialization (UFI) 
controls with additional restrictions and Safe for 
Initialization (SFI) controls with minimal restrictions dan 
Prompt me before enabling all controls with minimal 
restrictions. Apabila opsi ini dipilih, Excel akan me-
nampilkan peringatan dan menonaktifkan ActiveX Controls 
ketika workbook yang mengandung ActiveX Controls 
dibuka. Diaktifkan atau tidaknya ActiveX Controls ter-
gantung pada pilihan Anda. 



75 

 Enabled all controls without restrictions and without 
prompting (not recommended; potentially dangerous 
controls can run). Apabila opsi ini dipilih, ActiveX Controls 
dalam workbook akan selalu diaktifkan. Opsi ini tidak dire-
komendasikan karena berpotensi menimbulkan kerugian. 

 Safe mode (helps limit the control’s access to your 
computer). Opsi ini digunakan untuk membatasi akses 
ActiveX Controls pada komputer, misalnya membatasi 
ActiveX Controls untuk mengubah registry sistem operasi.  
Beri tanda centang pada pilihan ini untuk mengaktifkan 
pengaturan safe mode. 

 

2.5.2 Menambahkan Kontrol 
Anda dapat menambahkan ActiveX Control melalui tombol Insert 
dalam tab Developer group Controls. Dalam contoh kali ini, kita 
akan menambahkan kontrol ListBox. 

1. Klik tombol Insert dalam tab Developer group Controls.  
Muncul tampilan seperti terlihat pada Gambar 2.32. 

 

Gambar 2.32 Memilih kontrol yang akan ditambahkan. 

2. Klik kontrol List Box (ActiveX Controls). Klik mouse pada 
bidang worksheet untuk menambahkan kontrol ke dalam 
worksheet. 
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Gambar 2.33 Menambahkan kontrol ListBox. 

Ukuran dan posisi kontrol dapat diubah menggunakan mouse, 
kotak dialog Format Control, window Properties atau menggu-
nakan kode Macro. Untuk mengubah ukuran dan posisi kontrol 
menggunakan mouse, pastikan tombol Design Mode dalam 
keadaan aktif. Setelah tombol Design Mode aktif, Anda baru dapat 
menyeleksi kontrol yang akan diubah ukuran atau posisinya. Cara 
mengubah ukuran dan posisi ActiveX Control pada prinsipnya 
sama dengan cara mengubah ukuran dan posisi kontrol pada 
UserForm.   

2.5.3 Kotak Dialog Format Control 
Kotak dialog Format Control merupakan kotak dialog untuk 
melakukan pengaturan berbagai hal yang berkaitan dengan 
ActiveX Controls. Berikut pengaturan ActiveX Controls melalui 
kotak dialog Format Control.  

1. Klik kanan kontrol kemudian pilih menu Format Control…  
Muncul kotak dialog Format Control. Pilih tab Size untuk 
mengatur ukuran kontrol. 

 

Gambar 2.34 Kotak dialog Format Control - tab Size. 
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 Ketikkan tinggi kontrol yang Anda inginkan pada kotak isian 
Height: pada pilihan Size and rotate. Anda juga dapat 
menentukan tinggi kontrol berdasarkan persentase ukuran 
kontrol saat diubah melalui kotak isian Height: pada pilihan 
Scale. 

 Untuk menentukan lebar kontrol, ketikkan lebar kontrol 
pada kotak isian Width: pada pilihan Size and rotate. Anda 
juga dapat menentukan lebar kontrol berdasarkan persen-
tase lebar kontrol saat diubah melalui kotak isian Width: 
pada pilihan Scale. 

 Agar perubahan ukuran kontrol selalu proporsional, beri 
tanda centang pada pilihan Lock aspect ratio. Setelah Anda 
melakukan pengaturan tersebut, Anda selanjutnya hanya 
tinggal mengubah tinggi atau lebarnya saja. Jika Anda 
mengubah tinggi, maka lebarnya akan menyesuaikan 
dengan ukuran yang proporsional. 

2. Klik tab Protection untuk mengatur apakah kontrol dapat 
dimodifikasi atau tidak. Pengaturan baru aktif saat worksheet 
dalam keadaan terproteksi. Beri tanda centang pada pilihan 
Locked agar kontrol tidak dapat dimodifikasi pengguna. 

 

Gambar 2.35 Kotak dialog Format Control - tab Protection. 

3. Klik tab Properties untuk melakukan pengaturan apakah 
kontrol akan ikut menyesuaikan jika ada perubahan range yang 
ditempati kontrol. 
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Gambar 2.36 Kotak dialog Format Control - tab Properties. 

 Move and size with cells digunakan untuk mengatur agar 
kontrol ikut berpindah dan berubah ukurannya menye-
suaikan perubahan range yang ditempati. 

 Move but don’t size with cells digunakan untuk mengatur 
agar kontrol ikut berpindah menyesuaikan perubahan range 
yang ditempati, namun ukurannya tidak berubah. 

 Don’t move or size with cells digunakan untuk mengatur 
agar kontrol tidak ikut berpindah dan tidak berubah 
ukurannya ketika ada perubahan range yang ditempati. 

 Untuk mengatur agar kontrol tidak ikut tercetak, hilangkan 
tanda centang pada pilihan Print object. 

4. Klik tab Web atau All Text (Excel 2010) untuk menambahkan 
teks alternatif pada web browser. Teks alternatif berfungsi untuk 
membantu mesin pencari menemukan kontrol dalam workbook 
yang disimpan secara online di internet. Ketikkan teks alternatif 
yang Anda inginkan pada kotak isian yang tersedia.   

 

Gambar 2.37 Kotak dialog Format Control – tab Web/All Text.  
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2.5.4 Memasukkan Nilai SpinButton ke TextBox 
Contoh penerapan ActiveX Control berikut digunakan untuk 
memasukkan nilai SpinButton ke dalam TextBox. Anda tidak 
dapat memasukkan nilai langsung ke dalam TextBox karena 
properti Enabled diatur ke nilai False. 

1. Tekan kombinasi tombol Ctrl+N untuk membuat workbook 
baru. Simpan workbook dengan nama Memasukkan Nilai 
SpinButton ke TextBox.xlsm. 

2. Tambahkan Text Box dan Spin Button ke dalam worksheet 
Sheet1. Ubah serta atur posisi kontrol seperti Gambar 2.38. 

 

Gambar 2.38 Menambahkan Text Box dan Spin Button.  

3. Pengaturan properti masing-masing kontrol dapat dilihat pada 
tabel berikut: 

Objek  Setting Properti 

SpinButton  Name = spinNilai, Height = 18, Max = 100, Min = 0, 
SmallChange = 1, Width = 15 

TextBox  Name = txtNilai, BackColor = &H0000FFFF& (kuning), 
Enabled  =  False,  Height  =  18,  TextAlign  =  3‐
fmTextAlignRight, Width = 90 

 
4. Tekan kombinasi tombol Alt+F11 atau klik tombol Visual 

Basic dalam tab Developer group Code untuk membuka Visual 
Basic Editor. 
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5. Pilih objek Sheet1(Sheet1) dalam Project Explorer. Tekan F7 
pada keyboard atau pilih menu View > Code untuk menam-
pilkan window Code. Ketikkan kode Macro sebagai berikut:   

Private Sub spinNilai_Change() 
 
'TextBox diisi nilai SpinButton 
txtNilai.Value = spinNilai.Value 
 
End Sub 
 

 
6. Kembali ke program utama Excel. Jika semuanya dilakukan 

dengan benar, Anda tidak dapat memasukkan nilai secara 
langsung ke dalam TextBox. Anda hanya dapat memasukkan 
nilai ke dalam Text Box melalui Spin Button.  

 

Gambar 2.39 Memasukkan nilai Spin Button ke dalam Text Box.  

2.6 Form Control dan Shape 
Selain menggunakan ActiveX Control, Anda juga dapat menja-
lankan Macro melalui objek yang ditempatkan dalam worksheet 
menggunakan Form Control atau Shape (kurva terbuka ataupun 
kurva tertutup). Excel menyediakan banyak bentuk Shape me-
narik yang dapat Anda pilih sesuai kebutuhan.   

1. Tekan kombinasi tombol Ctrl+N untuk membuat workbook 
baru. Simpan workbook dengan nama Nilai Kotak Pesan.xlsm  

2. Untuk membuka Visual Basic Editor, tekan kombinasi tombol 
Alt+F11 pada keyboard atau klik tombol Visual Basic dalam 
tab Developer group Code. 

3. Pada jendela Visual Basic Editor pilih menu Insert > Module.  
Ketikkan kode Macro berikut pada window Code Module1: 

Sub HapusData() 
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'Menghapus seluruh data dalam worksheet aktif 
Cells.ClearContents 
 
End Sub 
 

 
4. Kembali ke program utama Excel. Untuk menambahkan Form 

Control, klik tombol Insert dalam tab Developer group Controls.   

 

Gambar 2.40 Memilih kontrol yang akan ditambahkan. 

5. Pilih salah satu kontrol yang akan ditambahkan, misalnya klik 
Button (Form Control). Untuk menambahkan kontrol, klik 
mouse pada bidang worksheet. Setelah kontrol Button ditam-
bahkan, muncul kotak dialog Assign Macro. Kotak dialog 
tersebut digunakan untuk mengaitkan kontrol Button dengan 
Macro. Pilih Macro HapusData kemudian klik tombol OK. 

 

Gambar 2.41 Kotak dialog Assign Macro. 

6. Untuk mengubah teks klik kanan Button kemudian pilih menu 
Edit Text. Mode edit teks kemudian aktif. Ketikkan Hapus 
Data. Jika sudah, klik mouse di luar bidang Button.  
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Gambar 2.42 Mengubah teks Button. 

7. Ubah ukuran dan posisi Button sesuai keinginan. Untuk menguji 
hasilnya, ketikkan sembarang nilai pada sel A1 dan C5, 
misalnya, ketikkan 12 pada sel A1 dan 184 pada sel C5. Klik 
tombol Hapus Data. Seluruh data dalam worksheet aktif akan 
terhapus, lihat sel A1 dan C5.   

8. Untuk menambahkan Shape, klik tombol Shapes dalam tab 
Insert group Illustrations.   

 

Gambar 2.43 Memilih kontrol yang akan ditambahkan. 

9. Pilih salah satu Shape yang akan ditambahkan, misalnya klik 
Rounded Rectangle. Untuk menambahkan Shape, klik mouse 
pada bidang worksheet.   

10. Untuk mengaitkan Macro, klik kanan Shape kemudian pilih 
menu Assign Macro… Muncul kotak dialog Assign Macro. Pilih 
Macro HapusData kemudian klik tombol OK. 

11. Untuk mengubah teks klik kanan Shape kemudian pilih menu 
Edit Text. Mode edit teks kemudian aktif. Ketikkan Hapus 
Data. Klik tombol Center  dalam tab Home group 
Alignment. Jika sudah, klik mouse di luar bidang Shape.  
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12. Ubah ukuran dan posisi Shape sesuai keinginan. Untuk 
menguji hasilnya, ketikkan sembarang nilai pada sel A1 dan 
C5, misalnya, ketikkan 12 pada sel A1 dan 184 pada sel C5.  
Klik tombol (Shape) Hapus Data. Seluruh data dalam work-
sheet aktif akan terhapus, lihat sel A1 dan C5.   

 

Gambar 2.44 Form Control dan Shape. 
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