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Report Warga 
 
 
 
 
 
Setelah membuat FormWargaGrid dan FormFilmGrid, kini Anda akan 

membuat Report untuk masing-masing tabel tersebut. Dalam bab ini, 

Anda dipandu untuk membuat Report Warga dengan memanfaatkan 

fitur Crystal Report. Untuk membuat Report Film, Anda dapat latihan 

sendiri dengan memakai cara yang sama. 

9.1 Membuat Report Warga 
Sebelum membuat Report Warga, di komputer Anda harus sudah diinsta-

lasi Crystal Report (lihat Lampiran 1: Instalasi Crystal Report untuk 

VB2010). Report Warga merupakan laporan untuk data-data Warga 

rental vcd, sehingga Anda dengan mudah melihat Warga yang menjadi 

Anggota. Langkah membuatnya sebagai berikut: 

1. Buat DSN (Data Source Name) atau ODBC (Open Database 

Connectivity), dengan memilih Control Panel di menu Start. 

2. Klik atau pilih menu System and Security di jendela Control Panel. 

3. Pilih menu Administrative Tools di jendela System and Security. 

4. Pilih Data Sources (ODBC) di jendela Administrative Tools. 
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5. Di jendela ODBC Data Source Administrator, pilih tab System DSN 

dan klik tombol Add. 

6. Pilih nama driver Microsoft Access Driver (*.mdb, *.aaccdb) dan klik 

tombol Finish di jendela Create New Data Source. 

7. Muncul jendela ODBC Microsoft Access Setup, ketik 

DSNDBRentalVCD di kotak Data Source Name. Lalu ketik Access 

2007 Database di kotak Description (keterangan), kemudian klik 

tombol Select…. 

8. Muncul jendela Select Database, arahkan Drives ke d: dan ke folder 

Debug, sehingga database DBRentalVCD.mdb berada pada kolom 

Database Name, kemudian klik tombol OK. 

9. Muncul kembali ke jendela ODBC Microsoft Access Setup dan 

terlihat database DBRentalVCD.mdb, klik tombol OK. 

10. Kembali ke jendela ODBC Data Source Administrator, klik tombol 

OK dan tutup jendela Control Panel. 

11. Anda ubah framework ke versi yang lebih rendah. Untuk memastikan 

Crystal Report didukung di VB2010, caranya klik kanan pada 

ProjectRentalVCD lalu pilih menu Properties, seperti berikut.  

 
Gambar 9.1 Menu Properties ProjectRentalVCD 



48 

12. Pilih tab Compile, seperti berikut.  

 
Gambar 9.2 Tab Compile 

13. Gulung layar ke bawah dan klik tombol Advanced Compile 
Options…, seperti berikut.  

 
Gambar 9.3 Tombol Advanced Compile Options 

14. Terlihat Target framework adalah .Net Framework 4 Client Profile.  

 
Gambar 9.4 Target Framework 4 Client Profile  
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15. Ubah Target framework dengan mengklik tombol panah ke bawah 
menjadi .Net Framework 3.5 Client Profile, kemudian klik tombol 
OK, seperti gambar berikut.  

 
Gambar 9.5 Target Framework 3.5 Client Profile 

16. Muncul informasi yakin untuk mengubah target framework di 
jendela Traget Framework Change, klik tombol Yes, seperti berikut.  

 
Gambar 9.6 Jendela Target Framework Change 

17. Untuk memasukkan komponen CrystalReport Viewer di jendela 
ToolBox pada folder Reporting, klik kanan di area ToolBox di bawah 
folder General dan pilih Choose Items…, seperti gambar berikut.  
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Gambar 9.7 Menu Choose Items 

18. Pilih tab .Net Framework Components dan komponen 
CrystallReportViewer dengan memberi tanda checklist (centang) 
pada kotak di depan komponen tersebut, kemudian klik tombol OK.  

 
Gambar 9.8 Komponen CrystallReportViewer 

19. Sehingga komponen CrystallReportViewer berada di folder Reporting 
pada jendela ToolBox, seperti Gambar 9.9.  
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Gambar 9.9 Komponen CrystallReportViewer di folder Reporting 

20. Untuk memasukkan komponen CrystalReport Viewer di jendela 
ToolBox pada folder Reporting, klik kanan di area ToolBox di bawah 
folder General dan pilih Choose Items…, seperti Gambar 9.10.  

 
Gambar 9.10 Menu Choose Items 

21. Pilih tab .Net Framework Components dan komponen 
CrystallReportViewer dengan memberi tanda checklist (centang) 
pada kotak di depan komponen tersebut, kemudian klik tombol OK.  
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Gambar 9.11 Komponen CrystallReportViewer 

22. Sehingga komponen CrystallReportViewer berada di folder Reporting 
pada jendela ToolBox, seperti Gambar 9.12.  

 
Gambar 9.12 Komponen CrystallReportViewer di folder Reporting 

23. Buka ProjectRentalVCD, klik kanan ProjectRentalVCD dan pilih 
menu Add > New Item…. 

24. Pilih template Windows Form dan klik tombol Add, seperti berikut. 
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Gambar 9.13 Template Windows Form 

25. Buat tampilan form, seperti Gambar 9.14. 

 
Gambar 9.14 Tampilan form FormReportWarga 

26. Atur properti Form, seperti tabel di bawah ini. 

No  Objek  Properti  Nilai 

1  Form1  Name  FormReportWarga 

2  Form1  ControlBox  False 

3  Form1  StartPositiom  CenterScreen 

4  Form1  Text  Form Report Warga 
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5  Form1  FormBorderStyle  FixedSingle 

6  Button1  Name  btnSelesai 

7  Button1  Text  &Selesai 

8  Button1  Font Style  Bold 

          Tabel 9.1 Pengaturan Properti FormReportWarga 

27. Pilih menu File > Save Form3.vb As…, seperti Gambar 9.15. 

 
Gambar 9.15 Menu Save Form As 

28. Simpan file dengan nama FormReportWarga. 

29. Tempatkan objek CrystalReportViewer dari ToolBox pada folder 
Reporting ke FormReportWarga dan atur properti Dock nilainya 
menjadi None, seperti gambar berikut. 

 
Gambar 9.16 CrystalReportViewer di FormReportWarga 
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30. Klik tombol Smart tag (tombol panah ke kanan) di pojok kanan atas. 

 
Gambar 9.17 Tombol Smart Tag 

31. Pilih menu Create a New Crystal Report…, seperti gambar berikut. 

 
Gambar 9.18 Menu Create a New Crystal Report 

32. Muncul jendela Create a New Crystal Report, seperti gambar berikut. 

 
Gambar 9.19 Jendela Create a New Crystal Report 

33. Ketik CrystalReportWarga.rpt pada kolom Specify a name for the 
new report, kemudian klik tombol OK. 

34. Muncul jendela Crystal Report Gallery, secara default (bawaan) 
memilih Using the Report Wizard dan klik tombol OK. 
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Gambar 9.20 Jendela Crystal Report Gallery 

35. Muncul jendela Standard Report Creation Wizard pada bagian Data, 
klik + pada Create New Connection, dan pilih (klik) folder ODBC 
(RDO), seperti gambar berikut. 

 
Gambar 9.21 Memilih folder ODBC (RDO) 

36. Muncul jendela ODBC (RDO) pada bagian Data Source Selection, 
pilih DSNDBRentalVCD pada kotak Data Source Name, kemudian 
klik tombol Finish, seperti Gambar 9.22. 
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Gambar 9.22 Jendela ODBC (RDO) 

37. Pada bagian Data, klik tanda + pada folder ODBC (RDO) dan pilih 
tabel Warga, klik tombol > seperti gambar berikut. 

 
Gambar 9.23 Bagian Data 

38. Sehingga tabel Warga ada di kolom Selected Tables dan klik tombol 
Next >, seperti gambar berikut. 

 
Gambar 9.24 Tabel Warga di kolom Selected Tables 
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39. Muncul jendela Fields dan klik tombol >> untuk memilih semua 
field tabel Warga, seperti gambar berikut. 

 
Gambar 9.25 Memilih semua field tabel Warga 

40. Sehingga semua field tabel Warga berada pada kolom Fields to 
Display dan klik tombol Finish, seperti gambar berikut. 

 
Gambar 9.26 Semua field Warga di kolom Fields to Display 

41. Sehingga tercipta file CrystalReportWarga, seperti gambar berikut. 

 
Gambar 9.27 File CrystalReportWarga.rpt 

42. Klik tab Main Report Preview di bawah CrystalReportWarga. 
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Gambar 9.28 Preview CrystalReportWarga.rpt 

43. Modifikasi untuk judul field NamaAng, AlamatAng, JKAng dan 
TglLahir, dengan klik kanan judul field lalu pilih menu Edit Text 
Object, sehingga hasilnya seperti gambar berikut. 

 
Gambar 9.29 Memodifikasi judul field 

44. Masukkan perintah di button Selesai, perintahnya sebagai berikut: 

Private Sub btnSelesai_Click(ByVal sender As System.Object, 

ByVal e As System.EventArgs) Handles btnSelesai.Click 

        Me.Close() 

End Sub 

45. Kemudian klik ikon Save All (Ctrl+Shift+S). 

46. Sebelum menjalankan FormReportWarga, pilih menu Project > 
ProjectRentalVCD Properties… dan atur Start form menjadi 
FormReportWarga. 

47. Untuk menjalankan program atau file FormReportWarga, klik ikon 
Start Debugging (F5), akan muncul keluaran FormReportWarga. 
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Gambar 9.30 FormReportWarga dijalankan 

48. Klik tombol Selesai. 

Catatan: Anda buat lagi untuk FormReportFilm. 
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Form Password 
 
 

 

Form_Password merupakan Form untuk hak akses sistem Rental VCD 

menggunakan tabel pswd di dalam database DBRentalVCD.mdb. 

10.1 Membuat ModuleUmum 
Untuk membuat moduleUmum, ikuti langkahnya sebagai berikut: 

1. Jalankan VB2010. 

2. Buka project dengan nama ProjectRentalVCD. 

3. Buat item baru dengan mengklik kanan project ProjectRentalVCD 

dan memilih menu Add > New Item…, seperti Gambar 10.1. 

 
Gambar 10.1 Menu New Item 



62 

4. Muncul jendela Add New Item, pilih Templates Module, ketik 

Moduleumum di kotak Name dan klik tombol Add, seperti berikut. 

 
Gambar 10.2 Jendela New Item 

5. Ketik script di dalam ModuleUmum, sebagai berikut. 

Public Function Koneksi() As OleDb.OleDbConnection 

        Dim con As OleDb.OleDbConnection 

con=New OleDb.OleDbConnection("Provider=Microsoft.Jet.OLEDB.4.0; 

Data Source=" & Application.StartupPath & "\DBRentalVCD.mdb") 

        Return con 

        con = Nothing 

    End Function 

Arti Perintah: Untuk mengoneksi ke database DBRentalVCD.mdb. 

6. Tampilan script di dalam ModuleUmum, seperti gambar berikut. 

 
Gambar 10.3 Isi ModuleUmum 
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7. Simpan dengan mengklik ikon Save (bergambar disket). 

8. Buat Form baru dengan mengklik kanan ProjectRentalVCD, pilih 

menu Add > Windows Form…. 

9. Muncul jendela Add New Item, ketik Form_Password dan klik 

tombol Add, sehingga muncul form seperti Gambar 10.4. 

 
Gambar 10.4 Form_Password 

10. Atur properti-properti objek yang ada di Form_Password. 

No        Objek      Properti                 Nilai 

1  Form  Text  Form_Password 

2  Form  ControlBox  False 

3  Form  StartPosition  CenterScreen 

4  Form  Name  Form_Password 

5  Label1  Text  Nama 

6  Label1  Font Style  Bold 

7  Label1  Name  lblNama 

8  Label2  Text  Password 

9  Label2  Font Style  Bold 

10  Label2  Name  lblPassword 

11  TextBox1  Name  TxtNama 
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12  TextBox1  Font Style  Bold 

13  TextBox1  MaxLength  30 

14  TextBox2  Name  TxtPassword 

15  TextBox2  Font Style  Bold 

16  TextBox2  MaxLength  30 

17  Button1  Name  BtnOK 

18  Button1  Text  &OK 

19  Button1  Font Style  Bold 

20  Button2  Name  BtnBatal 

21  Button2  Text  &Batal 

22  Button2  Font Style  Bold 

23  Button3  Name  BtnKeluar 

24  Button3  Text  &Keluar 

25  Button3  Font Style  Bold 

Tabel 10.1 Pengaturan Properti-Properti Objek di Form_Password 

11. Sehingga tampilan Form_Password setelah diatur propertinya, seperti 

pada Gambar 10.5. 

 
Gambar 10.5 Form_Password setelah diatur propertinya 

10.2  Memberi Perintah Form_Password 
Untuk membuat Form_Password, ikuti langkahnya sebagai berikut: 
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1. Buat metode bersih, menuju ke view code di jendela Solution 

Explorer (tekan tombol F7) langsung ketik perintah, sebagai berikut. 

Private Sub bersih() 

        Me.TxtNama.Clear() 

        Me.TxtPassword.Clear() 

        Me.TxtNama.Focus() 

    End Sub 

Arti Perintah: Untuk mengosongkan objek TextBox. 

2. Tampilan metode bersih di jendela view code, seperti berikut. 

 
Gambar 10.6 Metode bersih di jendela view code 

3. Kemudian klik ikon Save (bergambar disket). 

4. Buka kembali database DBRentalVCD.mdb, tambahkan tabel pswd, 

dengan struktur seperti table di bawah ini. 

No  Nama Field  Type  Size 

1  nama  Text  30 

2  password  Text  30 

        Tabel 10.2 Struktur Field Tabel pswd 

5. Untuk field nama sebagai kunci utama. 

6. Isi tabel pswd dengan 2 record, seperti tabel di bawah ini. 
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No Record  nama  password 

1  yuniar  admin 

2  ganesha  user 

        Tabel 10.3 Record Tabel pswd 

7. Untuk memberi perintah pada Button OK, klik dua kali button OK.  

8. Kemudian ketik perintah, sebagai berikut. 

Try 

            Dim da As OleDb.OleDbDataAdapter 

            da = New OleDb.OleDbDataAdapter("Select * from 

pswd where nama ='" & Me.TxtNama.Text & "'", 

ModuleUmum.Koneksi) 

            Dim dt As New DataTable 

            dt.Clear() 

            da.Fill(dt) 

            If dt.Rows.Count = 0 Then 

                MsgBox("Tidak Terdaftar, coba lagi!!!!") 

                bersih() 

                Exit Sub 

            End If 

            Dim dr As DataRow 

            For Each dr In dt.Rows 

                If Me.TxtPassword.Text = dr("password") Then 

                    MsgBox("Selamat Memakai Sistem Rental 

VCD " & vbCrLf & vbCrLf & "Ir. Yuniar Supardi" & vbCrLf & 

vbCrLf & "Tekan tombol Enter Utk Masuk", MsgBoxStyle.OkOnly) 

                    Dim forms As New Form_Password 

                    forms.lblNama.Text = 

UCase(Me.TxtNama.Text) 

                    Me.Hide() 

                    forms.ShowDialog() 
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                Else 

                    MsgBox("Password Anda Salah!!!") 

                    Me.TxtPassword.Clear() 

                    Me.TxtPassword.Focus() 

                    Exit Sub 

                End If 

            Next 

        Catch ex As Exception 

            MsgBox(ex.Message, MsgBoxStyle.Information) 

        End Try 

9. Klik ikon Save. 

10. Klik dua kali button Keluar, ketik perintah sebagai berikut. 

Try 

            Dim da As OleDb.OleDbDataAdapter 

            da = New OleDb.OleDbDataAdapter("Select * from 

pswd where nama ='yuniar'", ModuleUmum.Koneksi) 

            Dim dt As New DataTable 

            dt.Clear() 

            da.Fill(dt) 

            Dim dr As DataRow 

            For Each dr In dt.Rows 

                If Not Me.TxtPassword.Text = dr("password") 

Then 

                    MsgBox("Hanya Admin yang bisa 

Shutdown!!!") 

                    bersih() 

                    Me.TxtNama.Focus() 

                    Exit Sub 

                End If 

            Next dr 
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            MsgBox("Aplikasi ShutDown!!!", 

MsgBoxStyle.OkOnly) 

            End 

        Catch ex As Exception 

            MsgBox(ex.Message, MsgBoxStyle.Information) 

        End Try 

11. Klik ikon Save. 

12. Klik dua kali button Batal, ketik perintah sebagai berikut. 

bersih() 

13. Beri perintah (Event) KeyPress untuk objek TxtNama, caranya 

dengan mengklik objek TxtNama, kemudian pada jendela Properties, 

pilih ikon Event, kemudian pilih KeyPress dengan mengklik dua kali, 

sehingga muncul tulisan TxtNama_Keypress, ketik perintah berikut. 

If e.KeyChar = Chr(11) Then 

   Me.TxtPassword.Focus() 

End If 

Arti Perintah: Untuk fokus ke objek TxtPassword. 

14. Beri perintah (Event) KeyPress untuk objek TxtPassword, caranya 

dengan mengklik objek TxtPassword, kemudian pada jendela 

Properties, pilih ikon Event, kemudian pilih KeyPress dengan 

mengklik dua kali, ketik perintah sebagai berikut. 

If e.KeyChar = Chr(11) Then 

   Me.BtnOK.PerformClick() 

End If 

10.3  Menjalankan Form_Password 
Untuk menjalankan Form_Password, ikuti langkahnya sebagai berikut: 

1. Jalankan VB2010. 
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2. Buka project dengan nama ProjectRentalVCD. 

3. Buat StartUp Form menjadi Form_Password. 

4. Jalankan Form_Password, masukkan nama dan password. 

 
Gambar 10.7 Form_Password pertama dijalankan 

5. Klik tombol OK, muncul pesan, seperti Gambar 10.8. 

 
Gambar 10.8 Pesan selamat memakai Sistem Rental VCD 

6. Klik tombol OK, sehingga tampilan akhir Form_Password, seperti 

Gambar 10.9. 

 
Gambar 10.9 Tampilan akhir Form_Password 

7. Jalankan lagi dan masukkan data yuniar dan admin, kemudian klik 

tombol OK, seperti Gambar 10.10. 
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Gambar 10.10 Jalankan kembali Form_Password 

8. Klik tombol OK pada jendela ProjectRentalVCD. 

9. Kemudian ketik kembali yuniar dan admin, lalu klik kembali tombol 

Keluar, muncul pesan Aplikasi Shutdown dan klik tombol OK. 

 
Gambar 10.11 Aplikasi Form_Password ditutup 
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Form Peminjaman 
 

 
Setelah membuat database dan membuat tabel di dalamnya, kemudian 

Anda membuat program manajemen database untuk tabel master, seperti 

FormFilmGrid, FormAnggotaGrid, FormWargaGrid dan 

Form_Password. Sekarang waktunya Anda membuat program dengan 

memakai file tabel transaksi. 

Form_Peminjaman merupakan form transaksi yang memakai beberapa 

tabel, sehingga pembuatan programnya berbeda. 

11.1   Membuat Form Peminjaman 
Untuk membuat Form_Peminjaman, langkahnya sebagai berikut: 

1. Buat tampilan form seperti gambar berikut.  

 
Gambar 11.1 Tampilan Form_Peminjaman 
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2. Simpan file dengan memilih menu File > Save Form1.vb As…, 
kemudian ubah namanya menjadi Form_Peminjaman. 

3. Atur properti Form, seperti tabel di bawah ini. 

No  Objek  Properti  Nilai 

1  Form1  Name  Form_Peminjaman 

2  Form1  ControlBox  False 

3  Form1  StartPositiom  CenterScreen 

4  Form1  Text  Form Transaksi   
Peminjaman Film 

5  Form1   FormBorderStyle  Fixed Single 

6  Label1  Text  Tanggal Pinjam 

7  Label1  FontStyle  Bold 

8  DateTimePicker  Name  DateTimePicker1 

9  Label2  Text  No Transaksi 

10  Label2  FontStyle  Bold 

11  TextBox1  Text  Dikosongkan (dihapus) 

12  TextBox1  Name  TxtNoTransaksi 

13  Label3  Text  No Anggota 

14  Label3  FontStyle  Bold 

15  ComboBox1  Name  CboNoAnggota 

16  Label4  Text  Nama Anggota 

17  Label4  FontStyle  Bold 

18  TextBox2  Text  Dikosongkan (dihapus) 

19  TextBox2  Name  TxtNamaAnggota 

20  GroupBox1  Name  GroupBox1 

21  GroupBox1  Text  Rinci Film 

22  GroupBox1  Font Style  Bold 

23  Label5  Text  Kode Film 



73 

24  Label5  FontStyle  Bold 

25  ComboBox2  Name  CboKodeFilm 

26  Label6  Text  Judul Film 

27  Label6  FontStyle  Bold 

28  TextBox3  Text  Dikosongkan (dihapus) 

29  TextBox3  Name  TxtJudulFilm 

30  DataGridView1  Name  DataGridView1 

31  Button1  Name  BtnSimpan 

32  Button1  Text  &Simpan 

33  Button1  FontStyle  Bold 

34  Button2  Name  BtnBatal 

35  Button2  Text  &Batal 

36  Button2  FontStyle  Bold 

37  Button3  Name  BtnKeluar 

38  Button3  Text  &Keluar 

39  Button3  FontStyle  Bold 

          Tabel 11.1 Pengaturan Properti Objek Form_Peminjaman 

4. Sehingga tampilan Form_Peminjaman setelah diatur propertinya, 
seperti Gambar 11.2. 

 
Gambar 11.2 Tampilan Form_Peminjaman setelah diatur propertinya 
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5. Tempatkan DBRentalVCDDataSet, AnggotaTableAdapter, dan 
FilmTableAdapter, seperti Gambar 11.3. 

 
Gambar 11.3 Menempatkan DataSet dan TableAdapter 

11.1.1 Memberi Perintah Form_Peminjaman 

Untuk memberi perintah objek-objek di Form_Peminjaman, langkahnya 

sebagai berikut: 

1. Pada jendela Solution Explorer atau pilih menu View > Code atau 

tekan tombol F7, untuk menuju ke tempat pengetikan (code editor). 

2. Kemudian pada bagian Object pilih General dan pada bagian 

Procedure pilih Declarations, ketik perintah sebagai berikut. 

Imports System.Data.OleDb 

3. Pada jendela Solution Explorer pilih ikon View Designer atau pilih 

menu View > Designer atau tekan tombol Shift+F7, untuk menuju 

ke form. 

4. Pada jendela Solution Explorer atau pilih menu View > Code atau 

tekan tombol F7, lalu pada bagian Object pilih Form_Peminjaman 

dan pada bagian Procedure pilih Declarations, ketik perintah berikut. 
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Public strSql As String 

Public DB As OleDbConnection 

    Public CMD, CMD2 As OleDbCommand 

    Public ADP As OleDbDataAdapter 

    Public RS, RS2 As OleDbDataReader 

    Public DS As New DataSet 

    Dim SQL, SQL2, SQL3, SQL4, SQL5 As String 

5. Pada jendela Solution Explorer pilih ikon View Designer atau pilih 

menu View > Designer atau tekan tombol Shift+F7, untuk menuju 

ke form. 

6. Menuju ke tempat pengetikan, di bawah perintah deklarasi 

Form_Peminjaman, ketik subprogram OpenDB(), sebagai berikut. 

Public Sub OpenDB() 

        Dim LOKASI = "Provider=Microsoft.Jet.OLEDB.4.0;Data 

Source=" & Application.StartupPath & "\DBRentalVCD.mdb" 

        DB = New OleDbConnection(LOKASI) 

        If DB.State = ConnectionState.Closed Then 

            DB.Open() 

        End If 

End Sub 

7. Ketik kembali subprogram TampilkanRecordDetailPinjam() berikut. 

Sub TampilkanRecordDetailPinjam() 

        ADP = New OleDbDataAdapter("SELECT * FROM 

DetailPinjam", DB) 

        DS = New DataSet 

        ADP.Fill(DS, "DetailPinjam") 

        DataGridView1.DataSource = DS.Tables("DetailPinjam") 

End Sub 

8. Ketik kembali subprogram HapusText(), sebagai berikut. 
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Sub HapusText() 

        TxtNoTransaksi.Text = "" 

        CboNoAnggota.Text = "" 

        TxtNoKTP.Text = "" 

        TxtNamaAnggota.Text = "" 

        cboKodeFilm.Text = "" 

        TxtJudulFilm.Text = "" 

        TxtJenisFilm.Text = "" 

        TxtKeterangan.Text = "" 

        TxtKondisi.Text = "" 

        TxtStatusPinjam.Text = "" 

        TxtHarga.Text = "" 

End Sub 

9. Kemudian pada bagian Object pilih DateTimePicker1 dan pada 

bagian Procedure pilih KeyPress, ketik perintah sebagai berikut. 

If e.KeyChar = Chr(13) Then 

   Me.CboNoAnggota.Focus() 

End If 

10. Kemudian pada bagian Object pilih TxtNoTransaksi dan pada bagian 

Procedure pilih KeyPress, ketik perintah sebagai berikut. 

If e.KeyChar = Chr(13) Then 

   Me.CboNoAnggota.Focus() 

End If 

11. Pada jendela Solution Explorer pilih ikon View Designer atau pilih 

menu View > Designer atau tekan tombol Shift+F7, untuk menuju 

ke form. 

12. Klik dua kali tombol perintah Keluar, kemudian ketik perintah: 

Me.Close() 
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13. Kemudian pada bagian Object pilih Form_Peminjaman dan pada 

bagian Procedure pilih Load, ketik perintah sebagai berikut. 

DataGridView1.ClearSelection() 

Me.FilmTableAdapter.Fill(Me.DBRentalVCDDataSet.Film) 

Call OpenDB() 

SQL = "SELECT * FROM Anggota" 

CMD = New OleDbCommand(SQL, DB) 

RS = CMD.ExecuteReader 

CboNoAnggota.Items.Clear() 

Do While RS.Read() 

   CboNoAnggota.Items.Add(RS("NoAnggota")) 

Loop 

SQL2 = "SELECT * FROM Film" 

CMD2 = New OleDbCommand(SQL2, DB) 

RS2 = CMD2.ExecuteReader 

cboKodeFilm.Items.Clear() 

Do While RS2.Read() 

   cboKodeFilm.Items.Add(RS2("kodeFilm")) 

Loop 

Call HapusText() 

Call TampilkanRecordDetailPinjam() 

14. Kemudian pada bagian Object pilih cboNoAnggota dan pada bagian 

Procedure pilih Click, ketik perintah sebagai berikut. 

Try 

            If Not CboNoAnggota.Text = " " Then 

                Dim da As OleDb.OleDbDataAdapter 

                da = New OleDb.OleDbDataAdapter("Select * 

from Anggota where NoAnggota ='" & Me.CboNoAnggota.Text & 

"'", ModuleUmum.Koneksi) 

                Dim dt As New DataTable 
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                dt.Clear() 

                da.Fill(dt) 

                TxtNoKTP.DataBindings.Add("Text", dt, 

"NoKTP") 

            Else 

                Me.CboNoAnggota.Text = " " 

            End If 

        Catch ex As Exception 

            MsgBox(ex.Message, MsgBoxStyle.Information) 

        End Try 

        TxtNoKTP.DataBindings.Clear() 

        Try 

            If Not TxtNoKTP.Text = " " Then 

                Dim da2 As OleDb.OleDbDataAdapter 

                da2 = New OleDb.OleDbDataAdapter("Select * 

from Warga where NoKTP ='" & Me.TxtNoKTP.Text & "'", 

ModuleUmum.Koneksi) 

                Dim dt2 As New DataTable 

                dt2.Clear() 

                da2.Fill(dt2) 

                TxtNamaAnggota.DataBindings.Add("Text", dt2, 

"NamaAng") 

            Else 

                Me.TxtNoKTP.Text = " " 

            End If 

        Catch ex As Exception 

            MsgBox(ex.Message, MsgBoxStyle.Information) 

        End Try 

        TxtNamaAnggota.DataBindings.Clear() 

15. Pada bagian Object pilih cboNoAnggota dan pada bagian Procedure 

pilih LostFocus, ketik perintah seperti no. 14. 
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16. Pada bagian Object pilih cboNoAnggota dan pada bagian Procedure 

pilih SelectedIndexChanged, ketik perintah seperti no. 14. 

17. Kemudian pada bagian Object pilih cboKodeFilm dan pada bagian 

Procedure pilih Click, ketik perintah sebagai berikut. 

Try 

            If Not cboKodeFilm.Text = " " Then 

                Dim da As OleDb.OleDbDataAdapter 

                da = New OleDb.OleDbDataAdapter("Select * 

from Film where KodeFilm ='" & Me.cboKodeFilm.Text & "'", 

ModuleUmum.Koneksi) 

                Dim dt As New DataTable 

                dt.Clear() 

                da.Fill(dt) 

                TxtJudulFilm.DataBindings.Add("Text", dt, 

"Judul") 

            Else 

                Me.cboKodeFilm.Text = " " 

            End If 

        Catch ex As Exception 

            MsgBox(ex.Message, MsgBoxStyle.Information) 

        End Try 

        TxtJudulFilm.DataBindings.Clear() 

        Try 

            If Not cboKodeFilm.Text = " " Then 

                SQL = "Select * from Film where KodeFilm ='" 

& Me.cboKodeFilm.Text & "'" 

                CMD = New OleDbCommand(SQL, DB) 

                RS = CMD.ExecuteReader 

                RS.Read() 

                If RS.HasRows = True Then 

                    TxtJenisFilm.Text = RS.Item(4) 
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                    TxtKondisi.Text = RS.Item(7) 

                    TxtStatusPinjam.Text = RS.Item(8) 

                    TxtKeterangan.Text = RS.Item(6) 

                    If TxtKeterangan.Text = "DVD" Then 

                        TxtHarga.Text = 3000 

                    Else 

                        TxtHarga.Text = 2000 

                    End If 

                Else 

                    Me.cboKodeFilm.Text = " " 

                End If 

            End If 

        Catch ex As Exception 

            MsgBox(ex.Message, MsgBoxStyle.Information) 

        End Try 

        TxtJenisFilm.DataBindings.Clear() 

18. Pada bagian Object pilih cboKodefilm dan pada bagian Procedure 

pilih LostFocus, ketik perintah seperti no. 17. 

19. Pada bagian Object pilih cboKodeFilm dan pada bagian Procedure 

pilih SelectedIndexChanged, ketik perintah seperti no. 17. 

20. Pada jendela Solution Explorer pilih ikon View Designer atau pilih 

menu View > Designer atau tekan tombol Shift+F7, untuk menuju 

ke form. 

21. Klik dua kali tombol perintah Batal, kemudian ketik perintah berikut. 

Call HapusText() 

TxtNoTransaksi.Focus() 
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22. Pada jendela Solution Explorer pilih ikon View Designer atau pilih 

menu View > Designer atau tekan tombol Shift+F7, untuk menuju 

ke form. 

23. Klik dua kali tombol perintah Simpan, kemudian ketik perintah: 

If TxtStatusPinjam.Text = "Belum" Then 

            SQL = "SELECT * FROM Pinjam Where NoTransaksi='" 

& TxtNoTransaksi.Text & "'" 

            CMD = New OleDbCommand(SQL, DB) 

            RS = CMD.ExecuteReader 

            Dim SSP As String 

            SSP = "Pinjam" 

            RS.Read() 

            If RS.HasRows = True Then 

                Dim Stotal, I As Integer 

                Stotal = RS.Item(3) + TxtHarga.Text 

                TxtTotal.Text = Stotal 

                SQL2 = "UPDATE Pinjam SET NoTransaksi='" & 

TxtNoTransaksi.Text & "'," & _ 

                       "NoAnggota='" & CboNoAnggota.Text & 

"'," & _ 

                       "TglPinjam='" & DateTimePicker1.Text 

& "'," & _ 

                       "Total='" & Stotal & "'" & _ 

                       "Where NoTransaksi='" & 

TxtNoTransaksi.Text & "'" 

                SQL3 = "INSERT INTO 

DetailPinjam(NoTransaksi,KodeFilm,Harga,Keterangan)" & _ 

                 " Values('" & TxtNoTransaksi.Text & "','" & 

_ 

                 cboKodeFilm.Text & "','" & _ 

                 TxtHarga.Text & "','" & _ 

                 TxtKeterangan.Text & "')" 
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                SQL4 = "UPDATE Film SET StatusPinjam='" & 

SSP & "'" & _ 

                       "Where KodeFilm='" & cboKodeFilm.Text 

& "'" 

                SQL5 = "INSERT INTO 

DetailBayar(NoTransaksi,KodeFilm,Harga,Keterangan)" & _ 

                 " Values('" & TxtNoTransaksi.Text & "','" & 

_ 

                 cboKodeFilm.Text & "','" & _ 

                 TxtHarga.Text & "','" & _ 

                 TxtKeterangan.Text & "')" 

                CMD = New OleDbCommand(SQL2, DB) 

                CMD.ExecuteNonQuery() 

                Call BtnBatal_Click(sender, e) 

                Call TampilkanRecordDetailPinjam() 

                CMD = New OleDbCommand(SQL3, DB) 

                CMD.ExecuteNonQuery() 

                Call BtnBatal_Click(sender, e) 

                Call TampilkanRecordDetailPinjam() 

                CMD = New OleDbCommand(SQL4, DB) 

                CMD.ExecuteNonQuery() 

                Call BtnBatal_Click(sender, e) 

                Call TampilkanRecordDetailPinjam() 

                CMD = New OleDbCommand(SQL5, DB) 

                CMD.ExecuteNonQuery() 

                Call BtnBatal_Click(sender, e) 

                Call TampilkanRecordDetailPinjam() 

            Else 

                SQL2 = "INSERT INTO 

Pinjam(NoTransaksi,NoAnggota,TglPinjam,Total)" & _ 

                 " Values('" & TxtNoTransaksi.Text & "','" & 

_ 
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                 CboNoAnggota.Text & "','" & _ 

                 DateTimePicker1.Text & "','" & _ 

                 TxtHarga.Text & "')" 

                SQL3 = "INSERT INTO 

DetailPinjam(NoTransaksi,KodeFilm,Harga,Keterangan)" & _ 

                 " Values('" & TxtNoTransaksi.Text & "','" & 

_ 

                 cboKodeFilm.Text & "','" & _ 

                 TxtHarga.Text & "','" & _ 

                 TxtKeterangan.Text & "')" 

                SQL4 = "UPDATE Film SET StatusPinjam='" & 

SSP & "'" & _ 

                       "Where KodeFilm='" & cboKodeFilm.Text 

& "'" 

                SQL5 = "INSERT INTO 

DetailBayar(NoTransaksi,KodeFilm,Harga,Keterangan)" & _ 

                " Values('" & TxtNoTransaksi.Text & "','" & 

_ 

                cboKodeFilm.Text & "','" & _ 

                TxtHarga.Text & "','" & _ 

                TxtKeterangan.Text & "')" 

                CMD = New OleDbCommand(SQL2, DB) 

                CMD.ExecuteNonQuery() 

                Call BtnBatal_Click(sender, e) 

                Call TampilkanRecordDetailPinjam() 

                CMD = New OleDbCommand(SQL3, DB) 

                CMD.ExecuteNonQuery() 

                Call BtnBatal_Click(sender, e) 

                Call TampilkanRecordDetailPinjam() 

                CMD = New OleDbCommand(SQL4, DB) 

                CMD.ExecuteNonQuery() 

                Call BtnBatal_Click(sender, e) 
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                Call TampilkanRecordDetailPinjam() 

                CMD = New OleDbCommand(SQL5, DB) 

                CMD.ExecuteNonQuery() 

                Call BtnBatal_Click(sender, e) 

                Call TampilkanRecordDetailPinjam() 

            End If 

        Else 

            MsgBox("Film Sedang DiPinjam!!!!") 

            Call HapusText() 

        End If 

24. Kemudian pada bagian Object pilih TxtNoTransaksi dan pada bagian 

Procedure pilih LostFocus, ketik perintah sebagai berikut. 

Dim strSql = "SELECT COUNT(*) FROM DetailPinjam Where 

NoTransaksi='" & TxtNoTransaksi.Text & "'" 

CMD = New OleDbCommand(strSql, DB) 

Dim JmlRec = CInt(CMD.ExecuteScalar) 

If JmlRec >= 3 Then 

   MsgBox("Jumlah Film Di atas 3!!!") 

   Call HapusText() 

Else 

   CboNoAnggota.Focus() 

End If      

25. Pada jendela Solution Explorer pilih ikon View Designer atau pilih 

menu View > Designer atau tekan tombol Shift+F7, untuk menuju 

ke form. 

26. Simpan kembali Form_Peminjaman. 
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11.2 Menjalankan Form_Peminjaman 
Untuk menjalankan Form_Peminjaman, ikuti langkah-langkahnya se-

bagai berikut: 

1. Jalankan VB2010. 

2. Buka project dengan nama ProjectRentalVCD. 

3. Buat StartUp Form menjadi Form_Peminjaman. 

4. Jalankan Form_Peminjaman, masukkan data seperti Gambar 11.4. 

 
Gambar 11.4 Form_Peminjaman dijalankan 

5. Klik tombol Simpan. 

6. Terlihat peminjaman dengan no transaksi F00004 di datagridview. 
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Gambar 11.5 No Transaksi F000004 di DataGridView 

7. Untuk meminjam film kedua dalam no transaksi yang sama, ketik 

F000004 di kotak No Transaksi. Kemudian pilih A000001 untuk No 

Anggota yang sama. Pilih F0000002 untuk Kode Film dan klik tombol 

Simpan, seperti Gambar 11.6. 

 
Gambar 11.6 Meminjam film kedua 
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8. Klik tombol Simpan, sehingga terlihat dua record transaksi pemin-

jaman film dengan no transaksi F000004 dan total menjadi 5000. 

 
Gambar 11.7 Peminjaman film kedua terlihat di DataGridView 

9. Klik tombol Keluar. 


